0

I get this error trying to upload avrdude: stk500v2_ReceiveMessage(): timeout

It is Robotdyn Mega 2560 PRO MINI and a Robotdyn CH340 which I have connected like this: enter image description here

I installed the CH340 drivers from here https://sparks.gogo.co.nz/ch340.html and I can see it in the device manager. Connecting the Mega 2560 Pro Mini lights up the L and On LED but when pressing upload (testing with simple examples as Blink) I get the error and neither RX or TX lights up.

I have tried everything I can think of. What am I doing wrong?

I have confirmed that it is connected to the correct COM-port and I use these settings:

Board: Arduino/Genuino Mega or Mega 2560
Processor: ATMega2560 (Mega 2560)

I have also tried many different USB-cables, short and long, and USB 2.0 and USB 3.0 ports. I use Windows 10 64-bit.

  • why is the pin header not soldered to board? – Juraj Mar 27 at 5:09
  • It is now, took the picture before – joq3 Mar 27 at 5:22
  • @Juraj this is not the same error message? – joq3 Mar 27 at 20:00
  • 1
    but the same troubleshooting – Juraj Mar 28 at 6:25
  • I now have the adapter and it has swapped RX TX labels, so must be wired RX to RX, TX to TX – Juraj Oct 12 at 11:10
0

Try placing a 100nf capacitor on RST. That is usually required on an FTDI programmer.

See Edgar's post - https://arduino.stackexchange.com/users/47431/edgar

Not the answer you're looking for? Browse other questions tagged or ask your own question.