1

So I am following this tutorial to make my arduino display hello world and millis(), I got it to work for a minute, but then it stopped updating the milliseconds, and when I pushed the reset button it went blank. since then, It has been blank but I have double, triple, and qaudruple checked checked my wiring, and it is flawless. I tried it with both of my 16 segment displays, but to no avail. I have redone the wiring, but it is still blank. Does anybody know what I could be doing wrong?

I followed this diagram Fritzing diagram this is my code:

// include the library code:
#include <LiquidCrystal.h>

// initialize the library by associating any needed LCD interface pin
// with the arduino pin number it is connected to
const int rs = 12, en = 11, d4 = 5, d5 = 4, d6 = 3, d7 = 2;
LiquidCrystal lcd(rs, en, d4, d5, d6, d7); 

void setup() {
  // set up the LCD's number of columns and rows:
  lcd.begin(16, 2);
  // Print a message to the LCD.
  lcd.print("hello, world!");
}

void loop() {
  // set the cursor to column 0, line 1
  // (note: line 1 is the second row, since counting begins with 0):
  lcd.setCursor(0, 1);
  // print the number of seconds since reset:
  lcd.print(millis() / 1000);
}

This is the result (the screen is lit up, but there is no text even when turning the potentiometer) Picture of the Arduino connected to the LCD display

  • i'm having trouble scrolling down in your code listing ..... lol .... please list the text of the complete sketch .....remove the picture of the code – jsotola Mar 18 at 22:11
  • that is not a 16 segment display .... this is embeddedadventures.com/images/uploaded_images/… – jsotola Mar 18 at 22:16
  • 1
    Please do not post images of code, paste the code itself, select it all and then press {} to properly format it. Also this display is 16x2 character one, not a segment one. – Avamander Mar 18 at 23:20
  • ok, I didn't have it formatted right, my code is in text now – Asher Mar 19 at 1:30
  • 1
    I suspect that you wiggled a loose Dupont wire back to it's place. They're quite flimsy. In addition to that, please post your best theory as the answer and click on the check mark button to mark it as the correct answer, adding (SOLVED) to the title is not how Arduino SE works. – Avamander Mar 19 at 2:43
2

It is most likely that I wasn't providing enough power to the arduino, and or had the potentiometer set to the wrong point. according to this post, you shouldn't run the arduino and display off of USB, because it may not actually be providing 5 volts. So I plugged it into the wall using a DC adapter. It now works.

  • If it solved your problem, you can accept your own answer to mark the question as answered. – rsm Mar 19 at 20:17
  • It won't let me accept it until tomorrow – Asher Mar 19 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.