0

I’m attempting to connect with a Adafruit Huzzah Feather ESP8266 board. I’m running a 2018 mbp with Mojave. I loaded the Silabs driver (CP210) to connect with the onboard UART on Huzzah board. I got the Arduino IDE 1.8.8 installed and loaded the 2.5.0 ESP8266 library (I also tried library 2.4.2).

The serial port appears in the IDE (SLAB_USBtoUART). It also appears when I run the /dev/tty.* command and in About this Mac. From the IDE when I try to Get Board Info. Nothing. I get the message “Native serial port, can’t obtain info”. Everything seems good, except nothing from the IDE. I pulled up CoolTerm, set it the port and hit the reset on the Huzzah. I see data after hitting reset.

I run the Huzzah board from a powered USB hub through one of the USB-C ports. Tried different combinations, no luck.

I have a very old WIn7 machine, loaded everything like on my mbp, there I can get board info. I would run the IDE on it, except the machine is sooo slow. I would very much like to get it working on my mac. It seems so close, but no cigar.

  • did you try to upload to the board? the "Get Board Info" works only with some Arduinos – Juraj Feb 16 at 17:49
  • Yes, on the win7 machine I was able to upload to the board. – P. Barney Feb 16 at 19:17
  • and on Mac? do you have same error message? turn on verbose mode in Preferences. – Juraj Feb 16 at 19:20
  • I solved the problem. Thanks to @Juraj for suggesting turning on verbose mode. Thanks. Not getting Board Info from the IDE, I figured the port wasn't working. Ignoring the Board Info problem, I went to compile and upload a simple program. Without verbose mode on, it looked like it wasn't connecting up. In reality it was a problem with the esp8266 libraries. After fixing that issue all is good. – P. Barney Feb 16 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.