0

I'm very new to Arduino, and I've set up a seat with four 50kg load sensors embedded inside. These are connected to a load cell combinator, which is connected to a load cell amp using jumper wires. VDD is connected to 5V on the Arduino, and VCC to 3.3V, as I can't work out how to short them together.

I've tried switching the 5V and 3.3V headers to no avail. I've also tried changing the calibration.

The setup can be seen here: https://imgur.com/gallery/zv7cCmV

#include "HX711.h"

#define calibration_factor -7050.0 //This value is obtained using the SparkFun_HX711_Calibration sketch

#define DOUT 3
#define CLK 2

HX711 scale(DOUT, CLK);

void setup() {
  Serial.begin(9600);
  Serial.println("HX711 scale demo");

  scale.set_scale(calibration_factor); //This value is obtained by using the SparkFun_HX711_Calibration sketch
  scale.tare(); //Assuming there is no weight on the scale at start up, reset the scale to 0

  Serial.println("Readings:");
}

void loop() {
  Serial.print("Reading: ");
  Serial.print(scale.get_units(), 1); //scale.get_units() returns a float
  Serial.print(" lbs"); //You can change this to kg but you'll need to refactor the calibration_factor
  Serial.println();
}

I expected the readings to change when a new object was placed on the seat, however I continue to get zero readings.

Any help would be greatly appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.