0

I'm new to Arduino and I currently have an Uno R3 that when connected to my computer shows up in my device manager (as ATmega16U2) but doesn't show up as connected to the COMM port in the IDE.

To test the Arduino I plug in the Arduino to my computer through USB, boot up the IDE and try to upload the sketch that comes up when you start the IDE.

What I have tried

  • Using a different cable
  • Using a different computer (The main computer I have tested this out on is my desktop, the COMM issue occurred on my laptop as well)
  • Reinstalling the drives (My desktop says the best drivers are already there, I don't recall trying this on my laptop)
  • Plugging it into the exactly port it calls (COMM3 is what it looks at and with my desktop I have plugged it into Port_3 on Hub_3, I'm not sure whether or not the Hub matters)
  • I have experimented with using the reset button. I would hold it down as the IDE tried to upload. I did this only a few times.
  • 2
    You haven't mentioned what operating system you are using, nor which version of Arduino IDE you are using - instructions can be found at arduino.cc/en/Guide/ArduinoUno – Jaromanda X Feb 4 at 2:47
  • 2
    Looks like your system didn't initialize correct driver for your arduino. That driver translates USB into a COM. Please take a look at arduino.cc/en/Guide/DriverInstallation maybe this will help you. Check if your device manager sees the Arduino, and maybe try manually installing the driver. Update the question with what you found. – Filip Franik Feb 4 at 14:30
  • select the COM port in Tools menu of IDE – Juraj Feb 4 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.