-1

I tried to upload sketch to my RFDuino. I can select the RFDuino port. But I can't upload cos I can't select the RFDuino board.

I followed the installation steps listed here but I don't see RFduino package in Board Manager after I finished the steps above.

I am using Mac Mojave and Arduino IDE v1.8.9. I have tried it with v1.6.6 but results the same.

  • I get Error downloading http://rfduino.com/package_rfduino166_index.json – Juraj Feb 3 at 20:06
  • 1
    the company RFDigital is gone. no support. try a manual install – Juraj Feb 3 at 20:34
  • I had this problem with STM32 package. Go to Arduino15 folder(%appdata%) and delete download cache – SilvioCro Feb 4 at 11:34
  • @SilvioCro, did you try it? – Juraj Feb 4 at 17:00
  • @Juraj When I did those steps(in my case it was STM32 package - this link, it worked. Go AppData\Local\Arduino15 and delete package_index.json.sig and package_index.json files – SilvioCro Feb 4 at 18:07
1

Turns out that rfduino.com's domain is gone, so the link will always return with an error downloading. After reading this thread arduino.cc, @pert posted a link for the .json file that used to be at the website you have. I used this link on MacOS Mojave and Arduino v1.8.9 and it worked perfectly!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.