1

I know this problem has been reported multiple times but in my case I think there is a different light on it.
My desktop is a w7x64 box and I also have a notebook with w10.
Both system have the arduino IDE 1.8.5 with the latest updates.
The desktop though has more boards and drivers as it is my main development system.
I have at ATmega2560 clone with CH340 which used to work on my desktop about half a year ago when I tried to get an LCD touch shield to work.
Yesterday I tried to resume on it and I got the ubiquitous timeout error.

So I removed the shield and tried the basic blink sketch but no change.
I tried an arduino nano and there was no problem to upload the blink sketch.
Then I tried different USB cables and ports but the timeout problem with the ATmega persisted.

So I went to the notebook and the ATmega worked like a charm.
Now I know that the board is ok as well as the cable.
The port is also ok as the nano worked on it smoothly.
I also tried the upload from an elevated command prompt with the verbose option but it gave me no further clue.

The output is below:

C:\Users\Pete\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/bin/avrdude -vvvv -CC:\Users\Pete\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino14/etc/avrdude.conf -v -patmega2560 -cstk500v2 -PCOM34 -b57600 -D -Uflash:w:T:\TMP\arduino_build_330193/Blink.ino.hex:i  

avrdude: Version 6.3-20171130  
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/  
         Copyright (c) 2007-2014 Joerg Wunsch  

         System wide configuration file is "C:\Users\Pete\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0 -arduino14/etc/avrdude.conf"  

         Using Port                    : COM34  
         Using Programmer              : stk500v2  
         Overriding Baud Rate          : 57600  
STK500V2: stk500v2_open()  
STK500V2: stk500v2_getsync()  
STK500V2: stk500v2_send(0x1b 0x01 0x00 0x01 0x0e 0x01 0x14 , 7)  
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]  
STK500V2: stk500v2_recv(): avrdude: ser_recv(): programmer is not responding  
avrdude: stk500v2_ReceiveMessage(): timeout  

Does anybody have an idea how to further tackle the problem?

  • Is there a reason to stay behind with an old version? There has been problems with the version from the Microsoft Store. Try to remove the old version and install the newest: arduino.cc/en/Main/Software It is possible that the usb-serial drivers have a problem, perhaps you can try to remove them before installing the new version. It is also possible that there is a problem with the hidden "Arduino15" folder. You can delete that folder before installing a new version. – Jot Jan 26 at 9:35
  • if you upload a sketch that prints on Serial, does it print to Serial Monitor on your desktop? – Juraj Jan 26 at 9:50
  • I downloaded the 1.8.8 release of the arduino IDE but the version of avrdude is the same as on 1.8.6. Thus the command line output does show the same timeout problem as before. As I said the Nano works without problems. It can print on serial too. The Mega does not upload and the print on serial is not working on the desktop. On the notebook there is no problem printing on serial. – user333869 Jan 26 at 10:38
1

I found the problem coming from a mismatch of the port speed setting and the baudrate in the avrdude command. It seems that the ATmega is very sensitive to timing issues. After I did set everything to 115200 it works on my w7 box like on the notebook.

  • 1
    where did you set the baud rate? avrdude sets the baud rate – Juraj Jan 27 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.