0

I am weirded about the built-in "latest Temboo library" with the latest Arduino IDE; when a previous older code says to download the latest Temboo version < 2? (which I found this: https://temboo.com/download)

http://wirebeings.com/arduino-intruder-alarm.html

I am using Arduino Uno or Arduino Leonardo + an iDuino Yun shield to recreate the experiment above.

I keep getting errors like this:

No matching function for call to 'TembooChoreo::TembooChoreo()'? TembooChoreo SendSMSChoreo; Error Help

Arduino: 1.8.8 (Windows 10), Board: "Arduino Leonardo"

Build options changed, rebuilding all In file included from C:\Users\user\Documents\Arduino\intruderAlarmTest\intruderAlarmTest.ino:6:0:

E:\arduino\arduino-1.8.8\libraries\Temboo\src/Temboo.h:86:43: error: expected identifier before '(' token

#define TEMBOO_ERROR_ACCOUNT_MISSING (201)

                                       ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:264:13: note: in expansion of macro 'TEMBOO_ERROR_ACCOUNT_MISSING'

         TEMBOO_ERROR_ACCOUNT_MISSING       = 201,

         ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/Temboo.h:86:43: error: expected '}' before '(' token

#define TEMBOO_ERROR_ACCOUNT_MISSING (201)

                                       ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:264:13: note: in expansion of macro 'TEMBOO_ERROR_ACCOUNT_MISSING'

         TEMBOO_ERROR_ACCOUNT_MISSING       = 201,

         ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/Temboo.h:86:44: error: expected unqualified-id before numeric constant

#define TEMBOO_ERROR_ACCOUNT_MISSING (201)

                                        ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:264:13: note: in expansion of macro 'TEMBOO_ERROR_ACCOUNT_MISSING'

         TEMBOO_ERROR_ACCOUNT_MISSING       = 201,

         ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/Temboo.h:86:44: error: expected ')' before numeric constant

#define TEMBOO_ERROR_ACCOUNT_MISSING (201)

                                        ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:264:13: note: in expansion of macro 'TEMBOO_ERROR_ACCOUNT_MISSING'

         TEMBOO_ERROR_ACCOUNT_MISSING       = 201,

         ^

In file included from C:\Users\user\Documents\Arduino\intruderAlarmTest\intruderAlarmTest.ino:7:0:

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h: In member function 'char* TembooCoAPChoreo::getResponseData()':

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:247:41: error: 'm_respData' was not declared in this scope

     char* getResponseData() {return m_respData;}

                                     ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h: In member function 'char* TembooCoAPChoreo::getHTTPResponseCode()':

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:248:45: error: 'm_httpCodeStr' was not declared in this scope

     char* getHTTPResponseCode() {return m_httpCodeStr;}

                                         ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h: At global scope:

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:277:5: error: expected unqualified-id before 'protected'

 protected:

 ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:280:27: error: 'm_client' declared as reference but not initialized

     TembooCoAPClient& m_client;

                       ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:311:5: error: expected unqualified-id before 'protected'

 protected:

 ^

E:\arduino\arduino-1.8.8\libraries\Temboo\src/TembooCoAPEdgeDevice.h:314:1: error: expected declaration before '}' token

};

^

exit status 1 Error compiling for board Arduino Leonardo.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

Update: I found that by adding #include TembooYunShield.h and TembooYunShieldChoreo SendSMSChoreo; instead of TembooChereo SendSMSChoreo;

fixes most of the errors

except the @Temboo and @Twilio problem.

  • Sounds like they made a mess of it. Just delete it and download the official latest version of the library manually. – Majenko Jan 24 at 12:07
  • yeah how, I don't even understand there are different programming languages that I extracted from .zip or .jar. to raw folders and files and replaced my older Temboo with it. but it still doesn't work, I can't make temboo.com/download seem to work so I stick with the built in latest 1.2.1 Temboo library from Arduino 1.8.8. – John Doe Jan 24 at 12:21
  • Can anyone help me with this temboo? Who is really knowledgable with this? – John Doe Jan 24 at 12:30
  • arduino.meta.stackexchange.com/users/84/jfpoilpret stackexchange.com/users/2147199/cormac-driver Please, any of you kind sirs help me regarding the temboo latest version issue? to be uploaded to arduino-1.8.8\libraries\Temboo? anyone? – John Doe Jan 24 at 12:39
  • The problem appears to be because you are compiling for the Leonardo. If I compile for the Yun the examples work. If I compile for the Leonardo they fail with the messages you see. – Majenko Jan 24 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.