0

I have faced this problem for few years ago and I solved it on Ubuntu 14.04 but I don't know why my solution doesn't work right now on Ubuntu 16.04

The Error :

avrdude: ser_open(): can't open device "/dev/ttyACM0": Permission denied

I'm using the same solution from The guide

Here what I've done :

ls -l /dev/ttyACM*
from the result : The owner is "root" and the group with access is " dialout
Then I applied
sudo usermod -a -G dialout UserName
sudo chmod a+rw /dev/ttyACM0
Finally logged out and logged in .

After all should be worked but I still have the same Error , it doesn't work at all , I removed the software and re-installed it didn't work as well

  • sudo apt-get remove modemmanager – Majenko Jan 9 at 19:58
  • Are you sure with ttyACM0? My Arduinos always show up as ttyUSB0 – chrisl Jan 9 at 20:11
  • @chrisl Yes I'm sure . Any help ? – Mohammed Rizqallah Jan 10 at 10:26
  • @Majenko still ! , didn't solve it – Mohammed Rizqallah Jan 10 at 10:37
  • @chrisl Real Arduinos with an ATMega for the USB use CDC/ACM, so appear as ttyACMx. Clones that use other chips, or ancient Arduinos with an FT232 appear as ttyUSBx. – Majenko Jan 10 at 11:24

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.