0

there was a problem loading the sketch, writing that the BlynkSimpleSerial.h library is missing. I tried to find on the Internet I did not tell me how to fix this error.

 #include <SoftwareSerial.h>
 SoftwareSerial SwSerial(10, 11);
 #define BLYNK_PRINT SwSerial
 #include <BlynkSimpleSerial.h>
 #include <Stepper.h>

 const int stepsPerMotorRevolution = 32;  //No of steps per internal revolution of motor,4-step mode                                     
 const int stepsPerOutputRevolution = 32*64; //no of steps per revolution of the output shaft
 const int motorpin1 = 8;                    //Assign motor pins to board pins
 const int motorpin2 = 9;                    //
 const int motorpin3 = 10;                   //
 const int motorpin4 = 11;                   //

 // initialize the stepper library on pins 8 through 11, Motor rev steps, initialise firing sequence 1-3-2-4 blah blah
 Stepper myStepper(stepsPerMotorRevolution, motorpin1,motorpin3,motorpin2,motorpin4);  
 char auth[] = "4682e99d6c5747f7b06beb04e30ae3e4";

 void setup(){
   SwSerial.begin(9600);
   Blynk.begin(auth);
   myStepper.setSpeed(600); 
 }

 BLYNK_WRITE(1){
   myStepper.step(param.asInt());
 }

 void loop(){
   Blynk.run();
 }

error messages

Arduino: 1.8.7 (Windows 7), Плата:"Generic ESP8266 Module, 80 MHz, Flash, Enabled, ck, 26 MHz, 40MHz, QIO, 512K (no SPIFFS), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200"

wifistepper:4:36: error: BlynkSimpleSerial.h: No such file or directory

  #include <BlynkSimpleSerial.h>
                         ^

compilation terminated.

exit status 1 BlynkSimpleSerial.h: No such file or directory

I tried to reinstall Blynk did not help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.