Ive upgraded to Mojave. I've never used Arduino before. I was given Arduino Uno. Arduino Uno does not find any serial ports... can't load Blink example (the first step)

In blind frustration, I tried the three ports available... None of work.

I've loaded the CH34x_Install_V1.4.pkg to no avail.

How do I get a serial port package that will enable serial ports in general (and more importantly for arduino)

thx, Bruce On a related Note: the list of things that Mojave broke is long! To solve many problems, re-install xcode FIRST!!! and read articles on apache, there is a "new and improve" apache server embedded in mojave.

  • you have it mixed up .... the Arduino Uno does not detect a serial port ..... the MAC detects the Arduino Uno as a USB serial port which can then be selected in the Arduino IDE
    – jsotola
    Dec 26, 2018 at 7:40
  • 1
    OK. What can I do to get the serial port to show up in the IDE? Currently the IDE sees /dev/cs.Bluetooth-Incoming-Port, /dev/cu.BrucesiPhone-WirelessiAP and /dev/cu.SSDC Dec 26, 2018 at 18:05
  • I have this problem too ... plug the arduino into a USB port and nothing happens. (youtube.com/watch?v=mlejsgxOxrU)
    – Steve L
    Apr 26, 2019 at 1:32

1 Answer 1


If you are using a genuino or genuine Arduino, the most common cause of this is using a USB power only cable to connect rather than a data cable. (You only need the CH34x_Install_V1.4.pkg if you are running an Arduino clone based on that chipset)

If I ran the world, the USB standard would include some way to distinguish whether it's power only or power and data without having to test it with a multimeter. I know, I know, that's crazy talk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.