-1

I am using RTC DS1307 with "TINY RTC I2C modules" written on it.I had downloaded RTClib library from adafruit and using the example code. I connected GND->GND, VCC->5V, SDA->A4 and SCL->A5. However after connecting the VCC to 5V the "ON" Led does not lights up and the code is not getting uploaded. I tried connecting the VCC to 3.3 V the code gets uploaded but does not shows any output on the screen.

1

It seems an hardware problem on Arduino Uno board.

Try to connect the 5V pin of Arduino Uno to a digital pin (e.g D7) and write a program for read a digital pin.

int inPin = 7;     // digital pin 7
int val = 0;       // variable to store the read value

void setup()
{
  pinMode(inPin, INPUT);        // sets the digital pin 7 as input
}

void loop()
{
  val = digitalRead(inPin);     // read the input pin
  Serial.println(val);          // print read value on serial
}

If you're not able to load this sketch on your Arduino, most likely it's an hardware problem on Arduino.

  • But 5V of Arduino is drawing current to VCC of bluetooth HC05 module – Neha Farheen Dec 20 '18 at 10:52
  • You remove temporary the HC 05 module and try it. – leoc7 Dec 20 '18 at 13:34
  • I had tried that and I think there is some hardware problem with my RTC. – Neha Farheen Dec 21 '18 at 14:08
0

Soldering was not done properly. The vcc and ground got "short" that's what the shopkeeper said. We again soldered it on the other side. Now its working

0

Just another point,

From my experience, any module that uses a serial connection can disrupt the sketch uploading process to the Arduino.

The best is to upload to Arduino when all serial connections are dis-connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.