I'm very new to Arduino. I tried programming Attiny 85 module using Arduino as ISP. It worked fine few times. after that i'm getting below error.

Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.

I understand that i can override this step using -F option. But really cannot figure out how to use -F option in Arduino IDE. Please Help!

  • don't use -F. solve the problem with wiring
    – Juraj
    Commented Nov 21, 2018 at 8:18
  • i tried checking and changing jumpers multiple times. no luck.
    – Rajesh G
    Commented Nov 21, 2018 at 8:19

1 Answer 1


For what I know there is no easy way to pass custom options to avrdude via the Arduino IDE, but Sloeber (to which I'm a contributor) does.

Beware though, the -F option of avrdude command doesn't solve the problem, just forces to skip the device signature verification, but if your Attiny is returning such signature something else is wrong and you'll end up with a failed firmware upload anyway.

If the device was working and suddenly stopped it's more than probably a wiring issue, as already suggested in the comments. The second most probable cause, in my experience, would be a hardware issue: you might have accumulated some static charge and then touched the Attiny or any wire connected to it, destroying one of the ISP pins...

My bet is on the former: my experience with the latter is you get changing signatures in the form of 0xFFFF00, 0x0000FF and 0xFFFFFF but, luckily for me, this didn't occur so often to accumulate a true knowledge.

  • Are you aware the Sloeber site is down (3pm EST 2018-12-28). There’s also a bad cert on the site
    – RubberDuck
    Commented Dec 22, 2018 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.