0

Help Needed as I am little bit lost. I've procured a Pro Micro Board from sparkfun. Great little board and it work like clock work when using the standard Arduino Programming IDE.

Well Copied the code thru to the Eclipse Project, Hit compile and all seems well. But Trying to write the code to the device the following happens.


avrdude: Version 6.3-20171130 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2014 Joerg Wunsch

     System wide configuration file is "C:/Users/vente/.arduinocdt/packages/arduino/tools/avrdude/6.3.0-arduino14/etc/avrdude.conf"

     Using Port                    : COM5
     Using Programmer              : avr109
     Overriding Baud Rate          : 57600
     AVR Part                      : ATmega32U4
     Chip Erase delay              : 9000 us
     PAGEL                         : PD7
     BS2                           : PA0
     RESET disposition             : dedicated
     RETRY pulse                   : SCK
     serial program mode           : yes
     parallel program mode         : yes
     Timeout                       : 200
     StabDelay                     : 100
     CmdexeDelay                   : 25
     SyncLoops                     : 32
     ByteDelay                     : 0
     PollIndex                     : 3
     PollValue                     : 0x53
     Memory Detail                 :

                              Block Poll               Page                       Polled
       Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
       ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
       eeprom        65    20     4    0 no       1024    4      0  9000  9000 0x00 0x00
       flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
       lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
       signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

     Programmer Type : butterfly
     Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding

avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding Found programmer: Id = "F"; type = @ Software Version = �.u; Hardware Version = �. avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device? avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check.

avrdude: butterfly_recv(): programmer is not responding avrdude: error: programmer did not respond to command: leave prog mode avrdude: butterfly_recv(): programmer is not responding avrdude: error: programmer did not respond to command: exit bootloader

avrdude done. Thank you.


I've setup the Programming interface a as a Leonardo Board. AVR ISP.

For some reason It seems as if and it might be me that the usb does not reset? and go into programming mode.

Please Help

  • I am not familiar with that programming environment, but to enter the bootloader on those boards you have to open the serial port at 1200 baud then close it again. Normally the Arduino IDE does that for you. Does this system? Possibly not. – Majenko Nov 15 '18 at 10:54
1

I assume you use Eclipse Sloeber plugin for Arduino. For serial upload over USB using bootloader choose programmer Default. All other programmers are for flashing over ICSP.

enter image description here

  • Okay I have installed version 2018-09 (4.9). The Toolset loaded is Arduino C++ Tools 9.5.3.201809121146. It was loaded with the help of the Yatta Plug-in interface. Under the Board Configuration I Do not have the option to Select DEFAULT – Marthinus Venter Nov 15 '18 at 18:19
  • So you don't use Sloeber Arduino Eclipse plugin – Juraj Nov 15 '18 at 18:32
  • Just Re-installed my Eclipse and found Mutiple Issues.The Path was to long under windows and this caused Sloeber not to install. I moved it and all seems to be fine now. Thanks – Marthinus Venter Nov 15 '18 at 20:27
  • @MarthinusVenter, now I don't know. did my answer help or the problem was something else? – Juraj Nov 16 '18 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.