0

I have a Pro Micro board at which tried to upload a sketch with sparkfun's Pro Micro 3.3v processor selected.

After the upload completed successfully the board did not run again and is not even detected from the arduino ide anymore.

When I uploaded sketches with the leonardo 5.5v board selected everything went well and I had no problem. Now I can not burn the bootloader because of the arduino ide not detecting the board.

What can i do?

  • Nothing special, it was the sd example for listing the micro sd files that the ide has – George Sp Nov 9 '18 at 17:21
  • I think that the 3.3v selected version is what caused the problem but I do not know what to do – George Sp Nov 9 '18 at 17:22
  • if the sketch fails, USB is not handled. so you must activate the bootloader by activating reset twice. led should blink fast until it is active – Juraj Nov 9 '18 at 17:39
2

Problem solved! By taping twice the reset and holding it the second time I managed to program my board and now the arduino ide detectes it and it works as expected.

Taping and releasing the button twice did not work but holding it the second time worked for me. I am a almost complete noob in electronics for now so to me is black magic that not releasing the button did the job instead of what everyone else is suggesting.

I hope this helps a newbie sometime in the future that is frustrated with his/er bricked board

| improve this answer | |
  • 1
    and you know that I copied the comment from our chat about the not soldered board where you could not reset the board chat.stackexchange.com/transcript/message/47422785#47422785 – Juraj Nov 9 '18 at 18:01
  • @Juraj damn you are everywhere :P Soldering the pins was my problem indeed, I bought a soldering iron and some alloy, and now everything works just fine! – George Sp Nov 9 '18 at 18:08
  • score! THanks for this, probably in the manual I did not read. – Marc Nov 22 at 15:49
0

After bricking a few units I finally sat down and read the manual for my SparkFun Qwiic Pro Micro - USB-C (ATmega32U4). I also figured out the cause.

The cause of my unit bricking was bad code. Compiled and profiled fine, but crashed the unit when uploaded. As a result the port became unavailable and seemingly gone. In my particular case one brick was via and unsupported command in my source. The second brick was abuse of memory. Sketches would upload, then the unit dies and the no connection message pops up.

The solution for this unit was use of the reset switch with some key timing, and a trusted script to recapture the device. This page was all I needed to read, classif #RTFM syndrome.

The following is a layman version of events for those less fortunate having not endured decades of software brain melt.

Recovery in a Nutshell

The USB port/comm when working will/can flip between the "normal" mode and the bootloader mode. Bootloader is a mode where the devices is exposed and can receive code and special commands.

If something, like the code, is causing the device to crash, such as I had, then the desired USB/serial port is not available.

The Reset Switch

The reset switch may also be some pins to be shorted. The manual talks about high/low and resistance. Generally I have found you just short the damn thing, milage may vary. I used the button.

Per the instructions you can double tab the button and then I seem to trail off and not really absorb the rest. Eventually I got the pattern.

The Pattern

If you double click the reset button the device goes into boot loader for 8 seconds.

Find a short "hello world" sketch and have it ready.

Double tap the reset button and immediately upload the sketch.

That may not work...

When uploading a sketch the beginning of the upload is the compile step. This must complete before there is anything to ship to the device.

I had to click upload and then double tap and get the timing right. Eventually I would use the shortcut (CMD/CRTL + U). The sketch takes and the device is back to normal.

Hope this helps someone - I needed the dummy version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.