0

I have an Arduino Uno and ESP8266-01 Wifi module with me currently. So I'm going to use ESP8266 to connect to the MQTT broker to allow me publish data to other devices. However, I have a problem with uploading my sketch due to the following error:

error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

I uploaded the example sketch WIFIScan provided by Arduino IDE to test ESP8266 whether working or not, so the code is not a problem. This is how I connect ESP8266 to the laptop. enter image description here

The Arduino Uno is connected to my laptop through USB port.

1

RST to GND holds esp8266 in reset

  • So RST pin on ESP8266 should connect to ? Which pin on Arduino? – Conard Nov 1 '18 at 15:15
  • 1
    let reset unconnected – Juraj Nov 1 '18 at 15:23
  • @Conard, did it help? – Juraj Nov 2 '18 at 5:45
  • not really. I have tried many methods, watched many online tutorials and end up getting the same error. I have selected the Generic ESP8266 board and right port, but it still won't let me upload sketch to ESP8266 – Conard Nov 3 '18 at 14:03
  • do you have an empty sketch uploaded to Atmega? one without Serial.begin(). – Juraj Nov 3 '18 at 14:04
-1

There are so many issues when working with the ESP8266, try unplugging the Arduino, replugging and immediately reuploading. Also, make sure that you have the ESP8266 as the board selected and that you are using the right port.

Hope this works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.