3

How do I use the keyboard to cycle through Arduino windows on a mac?

In my System preferences, I have (default):

Keyboard -> Shortcuts -> Move focus to next window = Cmd ⌘ `

It works perfectly in all other programs, but in the Arduino IDE, it only swaps between the last two windows. If I have three(or more) windows open, it is a real pain to find the one in the background.

I am using fully updated MacOS 10.14 and Arduino IDE 1.8.7

  • That shortcut works for me. Which version of the IDE and OSX are you using? – VE7JRO Oct 23 '18 at 16:51
  • @VE7JRO: See edit. Have you tried to cycle through three or more windows? – hpekristiansen Oct 23 '18 at 16:58
  • Yes, I am able to cycle through 3 or more windows. I am using an old version of OSX and an old version the IDE. – VE7JRO Oct 23 '18 at 17:03
  • 1
    @VE7JRO: Thank you for your help. I now found that by adding shift (normally used for reverse cycle), I can get all windows. – hpekristiansen Oct 23 '18 at 17:42
4

In MacOS 10.14 and Arduino IDE 1.6.12, cmd` cycles through 5+ IDE windows properly, for me.

Update:

When you upgrade to Arduino 1.8.7,

I won't be. I've tried a couple of its point releases and have given up on it because its launch performance is so p...-poor. Maybe 1.9 will finally fix it.

Sloeber/Eclipse is my serious code-crunching IDE. I keep the A-IDE around for reference and for quick knock-off experiments because it's quick to launch.

Update 2:

The OP asked me to note that he

found that Cmd ⌘ Shift ` cycles through all windows (maybe in reverse).

Update 3:

In older IDE the reverse cycling with Shift doesn't work?

It works in both directions for me (shifted/unshifted).

  • My comment is gone. I did not delete it myself - I have no idea what is happening. Could you add the workaround for IDE 1.8.7 - for completeness? – hpekristiansen Oct 25 '18 at 16:58
  • In older IDE the reverse cycling with Shift doesn't work? – Juraj Oct 25 '18 at 19:24
3

Just by trying, I found that Cmd ⌘ Shift ` cycles through all windows (maybe in reverse).

  • So cmd ` doesn't work on current IDE but cmd shift ` does? Shift should only change direction. – Juraj Oct 25 '18 at 19:23
  • @Juraj: I do not know why you find it hard to understand, or why you reject a well meant edit. JRoberts and I found the same thing: in the new IDE 1.8.7 cmd+` does not work(as expected) while cmd+shift+` does. Now JRobert has made the change, that collects and completes the answer. – hpekristiansen Oct 25 '18 at 20:52
  • JRobert has only old IDE, he can't confirm your problem with new IDE, where according to you only the reverse cycling works as expected. (you should add the update about reverse cycling to the question) – Juraj Oct 27 '18 at 9:38
  • @Juraj: I can not figure out if you are trolling. Please go ahead and change what you want - I will not be spending more time on this. – hpekristiansen Oct 27 '18 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.