1

I'm attempting to run the example sketch SerialToSerialBT.ino. It's a pretty commonly used sketch. I successfully loaded it on one of my ESP32 chips last week, and was able to use a tablet serial port to send data back and forth.

However, since last night, I have not been able to get the sketch to successfully run. I've traced the issue to the execution of esp_bt_controller_enable(BT_MODE) in esp32-hal-bt.c, which isn't terribly useful. At this point, the chip's brown out detection goes off and it resets. I've made absolutely sure that there's not any actual power issues by running it on 5v power, and setting the onboard LED to blink to declare the repeated resets.

The maddening thing of this is that it can't be the chip. I have three ESP32 chips and the same happens on all three. It can't be the code, because I loaded the sketch successfully a week ago. My only remaining thought is that it's due to some library update, new library, or board config setting that I somehow changed. I've spent more than a day on this, and I'm out of ideas.

The chips are Geekworm Easy Kit ESP32-C1.

  • I have inexplicably "solved" the problem through stupid luck and exhausted inattention. I forgot I had the (unpowered) power rail on my breadboard hooked up to supply to the 3.3V pin (was trying lower voltage earlier), when I plugged it into the USB. This in turn was hooked to a capacitor and another ESP32. The light on the 2nd ESP alerted me to my mistake. When I removed power from the second ESP32, the bluetooth finally booted without browning out. Apparently, if I run a capacitor between the 3.3V and GND pins, I can boot up the bluetooth while running on USB or 5V power. What. – John Rhoades Oct 7 '18 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.