0

I have three different devices, none of them gets recognized on my new Thinkpad L380 running Windows 10:

  • Arduino Nano Clone with CH340G chip (USB2Serial)
  • NodeMCU (Lolin V3) with CH 340G chip (USB2Serial)
  • NodeMCU (ESP-WROOM-32) with CP2102 chip (USB2UART)

All three of them are recognized properly both on my desktop computer running Windows 10 (on USB 2.0 ports) as well as on my other laptop (Acer Switch Alpha 12, Win10, USB 3.0 port).

But even after hours of trying I was not able to connect those devices to my Thinkpad. Things I've tried so far:

  • Of course, simply installing the Arduino IDE and try plug'n'play
  • Downloading and installing the CH340G driver from the official website
  • Disabling Secure Boot, enabling testsigning mode and reinstalling the CH340G driver
  • For the CP2102 device I only tried installing the driver under "normal" Windows (e.g. no testsigning enabled) since it also worked that way on my desktop computer

I have to admit that it's been a while since I set up the drivers on my other laptop and desktop computer, but I cannot remember that there was anything unusual I had to do back then.

Does anybody else know about problems regarding Thinkpad laptops? At first I thought USB 3.0 might be the problem, but the Acer laptop works just fine with the USB 3.0 port.

Update

Somehow the laptop now at least recognizes the Arduino Nano clone in the device manager and I can choose the COM port in the Arduino IDE. I can't tell what made the difference. All I did was to plug in a dongle for a wireless mouse in the USB ports to verify that they are working with "normal" devices and afterwards the Nano was recognized at least with a yellow "!" in the device manager. I then was able to uninstall the CH340 drivers and reinstall them. The device manager now displays the Nano as correctly installed.

But uploading a sketch fails. It outputs the errors:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x0a
avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: Access denied

The RX LED is faintly blinking in red at the beginning of the process, then the upload seems to get stuck until the error messages are displayed.

The NodeMCU Lolin V3 with the same CH340 chip is still not recognized, though.

Serial communication (with the Serial monitor of the Arduino IDE) is now possible. I uploaded the "ASCIITable" example using my Desktop PC, connected the Arduino to the ThinkPad and could successfully read the output over the serial interface.

  • Using the CP2102 drivers from silabs will fail if your CP2102 is fake (as about 80% are). There are special "hacked" drivers you need (no idea where they are, I use Linux which never has any of these issues). – Majenko Oct 4 '18 at 18:15
  • Since the driver works on my Desktop Computer, I assume this should not be the problem. Anyway it would still not explain the behavior of the CH340G devices. – dudenr33 Oct 4 '18 at 19:43
0

I recently bought a cheap USB 2.o hub. Turns out that the CH340G devices are recognised if I plug them in the hub rather than in the laptop directly. Maybe this helps somebody else who is searching for a solution, even though I can't explain why the hub is making a difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.