0

So for a while I get some Arduino IDE problem which I can't solve. When I try to upload any kind of code to my Arduino, Arduino IDE just stay at "Uploading". I tried to use another Arduino but I get the same problem. I used Pro Mini, Nano and Uno but it's the same. Then I decided to upload my code from another PC but I get the same problem and so I can't find where the problem is.

Is the problem in all my Arduinos or in my computers?

Note: The code which I was uploading, was from Arduino examples.

I am using Windows 10 Pro x64 and in my console I get this error:

 avrdude: stk500_recv(): programmer is not responding 
 avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x57

marked as duplicate by VE7JRO, Greenonline, sempaiscuba, Juraj, jose can u c Apr 17 at 2:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • i used all kind of arduinos for example nano mini and uno. Of corse they are chines models but i installed CH340 driver. Аs far as it is concerned to ports i am sure that i use the right ports @abu-ahmed al-khatiri – Nikimiskata Sep 13 '18 at 12:42
  • 1
    If you are using a PC then the drivers should work, if it is a Mac then the drivers are notorious for not working correctly. Also, make sure that you are using a data USB cable and not a charging cable. – Greenonline Oct 15 '18 at 14:09
0

To solve this problem, you should google the error message "avrdude: stk500_recv()". The web shows countless records where this error comes up. The message indicates that the serial communication has malfunctioned, but incorrect driver or serial port is not the only way this can happen.

During upload, (1) Have you tried to reset the arduino, (2) ensure that the RX/TX pins are not in use?

0

You tried different PCs and different Arduinos, so the only constant is the Code and the USB cable I guess:

  1. Try another USB cable
  2. Try to upload another code

Do you have the same problem with any code you try to upload?

  • 2
    Such reply (and question) is more suitable as a comment. It is not an answer. – MichaelT Oct 15 '18 at 11:27
  • Why? If he changes the cable and it works, then it is the solution. I once had an connection issue and changing the cable solved it. I'm pretty sure it will fix it :) – Holger Oct 15 '18 at 11:32
  • 2
    Yes, until then, it's not a solution (i.e. answer). You can reword to make it more of an answer than a comment. – MichaelT Oct 15 '18 at 11:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.