I am trying to install Arduino IDE in my Raspberry Pi model 3 but it is unable to locate file path.

I use the following steps

sudo apt-get update && sudo apt-get install arduino 

and in result I found this

pi@raspberrypi:~ $ sudo apt-get update && sudo apt-get install arduino 
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease                 
Ign:2 http://repository.pi4j.com wheezy InRelease                
Hit:3 http://repository.pi4j.com wheezy Release    
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package arduino

I am searching for a solution but not able to understand what's the problem here.

Any ideas to make it work will be helpful.

  • Have you tried grabbing the Linux ARM build directly from arduino.cc/en/Main/Software and installing it? Have you tried searching for the package name? apt-cache search arduino Sep 10, 2018 at 7:37
  • Downloading the latest version from the arduino.cc is much better idea. If there is Arduino IDE available in the repository, it's usually super obsolete. For example version in Ubuntu repositories is 1.0.5.
    – KIIV
    Sep 10, 2018 at 8:56

1 Answer 1


Visit https://www.arduino.cc/en/Main/Software in your browser, and click the Linux ARM link under ‘Download the IDE’.

cd Downloads/
tar -xf arduino-1.8.3-linuxarm.tar.xz

Extract the file to your /opt directory, then open a Terminal and run the install.sh script to install.

sudo mv arduino-1.8.3 /opt
sudo /opt/arduino-1.8.3/install.sh

You will find Arduino IDE under Menu > Programming. Open the app to start programming your Arduino board.

Hope this helps.

  • 1
    worked for me! In the Arduino website you'll find two versions (32-bits and 64-bits). In my case (and it seems in the case of this example) the 32-bits worked fine. I'm using a Raspberry Pi 3B with an Arm v7. Aug 8, 2019 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.