My Arduino IDE is not getting started. It just crashes before opening up. I don't know what the problem is. It was working well enough before without any issues.

This is what I see after running the arduino_debug.exe in the command line

enter image description here

Note: I added a library (DHT) to work with my humidity and temperature sensor and since after then, this issue comes up. I tried to reinstall it like more than 7 times, but the issue still persists.

Please help me with it. Thanks.


The cause of the problem is that you have a corrupted library index file. The solution is to delete the file, which will force the Arduino IDE to download a (hopefully) uncorrupted fresh version from the Internet:

  1. Open the C:\Users\JK\AppData\Local\Arduino15 folder
  2. Delete the file library_index.json
  3. Try starting the Arduino IDE again

For anyone encountering this problem who is using an operating system other than Windows, the location of library_index.json is different:

On Linux:

/home/{username}/.arduino15 (a.k.a. ~/.arduino15)

On macOS:


If using the Arduino IDE in portable mode:

{Arduino IDE installation folder}/portable

The issue of a corrupted library index file preventing the Arduino IDE from starting has been reported to the Arduino developers and they are already working on a fix:



Had same issue when migrating from Arduino IDE 1.8.2 to 1.8.9

In my case, deleting just the library_index.json was not enough but a good hint.

I did also delete the subdirectories of "packages" directory (boards which I downloaded- the ESP32 board and the ESP8266 board), and all files (not folders) in C:\Users\\AppData\Local\Arduino15\ except the preferences.txt

This solved the issue for me.

  • thanks. it worked for me. one thing you might need to [re]consider is placing %username% in your directory path so it will be C:\Users\%username%\AppData\Local\Arduino15\ this way one can simply copy/paste it in terminal or file manager and go to the specified directory. anyway thanks a lot!
    – N.S
    Jun 10 '20 at 10:19

I had the same problem this morning when trying to launch the IDE (1.8.3). I'm running Linux Mint 18.

Running the IDE from the command line showed the following errors:

Arduino IDE 1.8.3 launch errors

The output hints at a problem with 'packages' so I renamed ~/.arduino15/package_index.json to package_index.json.old. The IDE was then able to be launched. 'package_index.json' can then be rebuilt by starting your boards manager through 'Tools->Board'.