2

I'm trying to make an automatic planter for herbs etc. I finally got everything 3D printed and wired together. But for some reason, the relay I'm using refuses to switch or enable certain connections. I'm confused because it worked perfectly - continuity-wise - during my initial testing or installation.

The relay model HERE. The relay is to be controlling the ground connection of both an 12v indoor grow light and 12v small water pump. I was a bit confused with the relay's wiring itself. First time using this type of relay. Anyway, I got it working; well previously.

Here are some video to help explain the issue:
https://www.youtube.com/watch?v=GUiHs28bvK8
https://www.youtube.com/watch?v=-xaj8q537x4

(After uploading, I hear that my phone's mic stops the tone of the multimeter a few seconds into each video. But trust me, the tone is constant throughout the duration of both videos. You may be able to hear it?)

closed as off-topic by per1234, Greenonline, sempaiscuba, VE7JRO, gre_gor Sep 2 '18 at 17:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Arduino, within the scope defined in the help center." – per1234, Greenonline, sempaiscuba, VE7JRO, gre_gor
If this question can be reworded to fit the rules in the help center, please edit the question.

  • remove the relay board from the enclosure and check again – jsotola Sep 2 '18 at 1:12
  • Tearing it all apart is the very last thing I'd want to do. It's all held together with hot glue lol. Will do if it gets to that point ... But if that was the situation, I'd just buy another relay module I'm familiar with instead of dealing with this one. – dev deque Sep 2 '18 at 2:04
  • 1
    Listening to the sound of the relay, it does turn on and off. Therefor your 12v has enough power. Could there be a shortcut between the pins in the circuit? Remove the wires from the screw terminals. After that, remove the relay board. Is the multimeter okay? I often measure 0.1 or 0.2 instead of 0.0 ohm. – Jot Sep 2 '18 at 5:17
  • 1
    The first video indicates there is a short between the NO and the NC terminal. – Gerben Sep 2 '18 at 13:14
  • I tried messing with it again today and got it working to some degree... So I moved the VCC on the relay to the other VCC, furthest from the JD-VCC pin. Afterwards, I was able to get the expected behavior from the first two terminals of each relay. The pump and lights are working great even at the same time. However, the first and third of each relay isn't working right. They only activate if both relays are on at the same time.... Obviously some sort of wiring issue here I'll have to figure out. Thanks for the advice everyone. – dev deque Sep 2 '18 at 13:39

Browse other questions tagged or ask your own question.