0

Frontside of board[![][1]]2I am using an Arduino Nano board. It has an ATmega 328P processor. For running the codes I use Arduino 1.8.6 Software. The issue is that when I am uploading my sketch to the board it shows me the following errors:

 Using Port                    : COM7
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x9b
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x9b

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

I have turned on the show verbose output option turned on.

Also, sometimes the following errors pop up:

collect2.exe: error: ld returned 255 exit status

Using library SoftwareSerial at version 1.0 in folder: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.14.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\libraries\SoftwareSerial 
exit status 1
Error compiling for board Arduino Nano.

I have referred the following links to solve my issue:

I am making an application wherein I have to control two DC motors via Bluetooth module HC-05

In one of the troubleshooting questions, the solutions contained the possibility of the bootloader not being installed where the problem can be verified by pressing the reset button and checking the bootloader LED to blink. Can someone help me with this?

Also, there are two processors shown for ATmega328P:

  1. The ATmega328P
  2. The ATmega328P (old bootloader)

I tried using then both options for uploading the sketch but still, the errors pop up.

I have also downloaded and installed the latest FTDI drivers from their site.

marked as duplicate by gre_gor, VE7JRO, sempaiscuba, Greenonline, Juraj Aug 30 '18 at 6:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you tell which nano board you have? You can give a link to it or a photo of both sides. – Jot Aug 29 '18 at 11:15
  • Has this PC->cable->Nano combination ever worked, or is any of those components new? If these are new & untested, have you confirmed the settings: Tools > Board, Tools > Port, and Tools > Programmer? And if they once worked and now don't work, have you tried substituting each of them for known working ones? Will this Nano upload a Blink program from a different PC? – JRobert Aug 29 '18 at 12:45
  • No, I tried for upload blink programme also but didn't work. Also, the components used are tested and are working or have been directly taken from the manufacturer website – huzefa.s Aug 29 '18 at 12:56
  • The ch340g usb-serial chip is not officially supported by Arduino. You need an extra driver for your nano clone. For windows try this: wch.cn/downloads/CH341SER_EXE.html – Jot Aug 29 '18 at 14:41
-1

A common solution is to actually switch the board type to the Arduino Uno. It is a known problem but I have yet to see any other viable fix.

  • the 'new' bootloader option is the same as changing board option to Uno – Juraj Aug 30 '18 at 6:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.