1

I have a HC-05 module which works absolutely fine with an Arduino Uno. Because I need to reduce the size of it, I tried using an Arduino Nano.

After correctly wiring it up to the Nano, sometimes the LED doesn`t turn on, or sometimes it does not appear in the devices listing of my smartphone. It also resets randomly the Arduino. I have tested it and it fully works without any problems with the Uno.

I think it is a power issue, but not from my computer or any other computer because I tried on all my computers.

  • Are you powering it from 3.3V or 5V? – Majenko Aug 23 '18 at 13:35
  • 1
    the regulator on the nano may not be able to supply enough current for the HC-05. See if you can find a part number on the regulator and look up its specs. – Chad G Aug 23 '18 at 15:35
  • @ChadG If it's running from the 3.3v pin then it may even be using the internal 3.3v regulator of the CH340G, in which case you'd be lucky to get a few tens of mA from it... – Majenko Aug 23 '18 at 16:28
  • 1
    Please provide a schematic and the type of HC-05 module you have. The HC-05 itself runs in 3.3V, but most modules, that you can buy, add an extra voltage regulator for 5V, so that you can power it directly from the Arduino. – chrisl Aug 23 '18 at 21:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.