0

I've been getting this very common error on my atmega328pu circuit.

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x83

Some things iv'e tried are:

  • Restarting my comp
  • Reuploading the bootloader
  • Redownloading old version of arduino IDE
  • Using an FTDI chip and placing the chip inside an Uno

After I bootloaded the chip I was able to upload a blink sketch. Then the next time I tried I got this error. Anyone know what could be up? This is driving me crazy!

Circuit as built

marked as duplicate by Avamander, sempaiscuba, Juraj, VE7JRO, Greenonline Nov 26 '18 at 18:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

The first thing you should do is add a 0.1uF capacitor connected "in series" with the jumper wire from the DTR terminal of the FTDI programmer to pin 1 of the Atmega328P-PU chip. For most people, this will solve the problem.

I see you also have a "push button reset switch". If you can press/release this button at precisely the right moment, the sketch should upload without error. Using the Arduino IDE, if you click on the "Upload" button then press and release the "push button reset switch" just after the Arduino IDE's black console window shows you the line starting with:

Sketch uses x bytes (y%) of program storage space...

there is a good chance it will work. You can try holding the "push button reset switch" down for 1 to 1.5 seconds.

Please add a capacitor to the DTR circuit or disconnect it from the Atmega328P-PU before you go any further. A DTR connection to the programmer is not needed for the "push button reset switch" method of uploading and a "direct, hard wired connection" could cause an issue.

  • Hey I just tried the capacitor and it didnt work :( I would try the pushbutton but binary sketch size doesnt show up in the log. I have enabled the show verbose as well. – Brian Tipold Jul 29 '18 at 2:51
  • OK. Leave it in the circuit and try uploading using the method with the push button switch. – VE7JRO Jul 29 '18 at 2:53
  • I accidentally send that first part. I updated the comment. the binary sketch size doesnt show up in the verbose readout – Brian Tipold Jul 29 '18 at 2:59
  • I'm using a very old version of the IDE, so it's possible they changed the words "Binary sketch size: " to something else. Sorry I can't help you with that part of your question. Could you update your question and tell us which version of the IDE and which computer operating system you are using? – VE7JRO Jul 29 '18 at 3:06
  • 1
    With any modern IDE version, the equivalent output is the line starting with: "Sketch uses x bytes (y%) of program storage space..." – per1234 Jul 29 '18 at 4:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.