1

Using Raspbian Stretch.

I installed gcc-4.9 with specified version. Then I installed arduino (2.1.0.5) which in turn pulled gcc 4.6. When I try to compile Marlin in it, it says

Marlin requires C++11 support (gcc >= 4.7, Arduino IDE >= 1.6.8). Please upgrade your toolchain.

How do I make Arduino IDE use the correct version of GCC?

  • I think this is a question to ask on Debian forum and not here. – Filip Franik Jul 26 '18 at 16:14
  • Why on earth did you install such an ancient version? Delete it and download the current (i.e., released this decade) version. – Majenko Jul 26 '18 at 16:15
  • @Majenko, these are the newest versions. packages.debian.org/stretch/gcc packages.debian.org/stretch/arduino – Dmitry Fedorkov Jul 26 '18 at 16:17
  • 1
    No, those are versions that were submitted to Debian years ago. You don't install Arduino from the Debian repositories. You haven't done for many many years. Download the Arduino IDE from the Arduino website. – Majenko Jul 26 '18 at 16:17
2

As Majenko pointed out, I should have used a tarball from the official site instead of the repositories. Which makes me wonder why that package wasn't deprecated or something...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.