0

I'm trying to create an Arduino Uno following the circuit described in the diagram below which I'd based from here.

I'd tried this circuit on an Atmega328 PDIP version (with the correct connections since the PDIP has different pinouts from this TQFP) and I was successful in creating and using my own Arduino.

However, when I've used the TQFP version and had this circuit layout and printed on a pcb, I can't burn the bootloader using an Arduino UNO.

I've double checked the pinouts from the Atmega328P datasheet and they are correct. Using a tester, I've also verified that the connections are there.

By the way, I've used the following connections.

Arduino Digital Pin 13 to SCLK
Arduino Digital Pin 12 to MISO
Arduino Digital Pin 11 to MOSI
Arduino Digital Pin 10 to RESET
Arduino 5V to VCC
Arduino GND to GND

I've also burned the ArduinoISP program on th Arduino UNO, selected Arduino as ISP and chosen Arduino UNO as board.

When I press 'Burn Bootloader', I'm getting this error message.

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
     Double check connections and try again, or use -F to override
     this check.

I've looked at different forums and they are only saying to check the connections which I'd already checked that there is.

enter image description here

1

I have had this problem in the past and it has always been one of two solutions

  1. The wires were misconfigured, and I only saw it after the Nth time
  2. Wrong chip, I was trying to program a 328 when it expected a 328p

And the secret third option:

  1. Some chip/wire/etc. was busted/burned/bad.

Unfortunately These were the only outcomes to ever come for me when I encountered that particular error.

  • I've checked the connections a lot of times today and they were correct. Also, I've wrongfully placed an Atmega328PB before. Upon making necessary software changes, I've successfully burned a bootloader. It is also a correct chip now that I'm having this issue. And I've used 3 chips by now and changed a lot of wires so I would want to rule that out? – noobiejp Jul 24 '18 at 6:52
1

Arduino on breadboard here is a Link... https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard

If bootloader is burned with arduino uno in atmega328 then code will be uploaded for once and run correctly but next time you tried to burn code in atmega328 then code will not burn in atmega328. I also tried this way but it just work one time for me then I bought usbasp(price 1.5$) to burn bootloader permanently. after burning bootloader with usbasp then its works perfect for me. Just connect crystall with filtering capacitor thats enough to burn bootloader. above config is just in case you want to use it as MCU.

  • That's actually the link where I'd based my circuit. Also, I've just bought the chips so I think there are no bootloaders in them. I've tried reburnong the bootloader on the Atmega328p DIP that I've used before. It's working. – noobiejp Jul 24 '18 at 5:32
0

The design is missing 0.1uF caps on VCC, AVCC, and Aref.

Aref should not connect to 5V directly. It is connected internally thru a mux and only needs the 0.1uF to Gnd. If Aref is direct connected and then the sketch selects the internal 1.1V reference, it can/will damage the chip.

Change the 220 ohm resistor on D13/SCK to 1K. 220 ohm puts quite a load on the SCK line for a Programmer. 1K will result in a plenty bright LED.

Do you have a 0.1uF between DTR of a Serial programmer and the Reset pin? A Programmer needs direct control of the Reset line, a Serial programmer (such as an FTDI Basic module) needs to go thru a cap so a Reset pulse is created.

  • Actually, I have a cap between VCC, AVCC and GND that I haven't included in the screenshot. Now that you've mentioned it, I'm seeing a small arc (spark) on the AREF pin. What I've done is I'd lifted the pin out to disconnect it from AVCC and VCC, and soldered a 100nF cap to GND. What it did however is create a larger arc on the pin. – noobiejp Jul 24 '18 at 6:55
  • Also, before, I'd ordered Atmega328PB instead of Atmega328P. I'm getting an error on device signature then. I've done some modifications based on different forums and was successful on burning a bootloader and uploading a sketch. Now, I've got the correct Atmega328P, installed on the same layout and I'm having this problem. – noobiejp Jul 24 '18 at 6:58
  • By arc, you mean you are seeing sparks? That's not good at all. Is your 5v line ok? – CrossRoads Jul 24 '18 at 12:00
  • Yes, I mean spark. And I can't understand why. The 5V line is ok. Seeing some spikes on oscilloscope whenever a spark forms on the AREF pin though. – noobiejp Jul 24 '18 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.