I'm using a SIM800C module, and usually it works fine, but lately it has started giving the error "+CPIN: NOT READY" with ERROR CODE : +CME ERROR: 10(SIM NOT INSERTED). As soon as I get this message, the voltage on SIM_VDD drops to 0V. The problem is intermittent (i.e. it happens only sometimes).

I have read all related posts on here. Here is some info on my setup: -Schematics is designed according to SIM800C documentation. -I use 6-pin SIM connector. -Adding decoupling caps on SIM_VDD, on input power, and on VBAT (for SIM900) does not help. -Signal strength is fine (about CSQ=20). -I tried reinserting different SIM cards, nothing helped

The "+CPIN: NOT READY" is sent at different times, however, often quite soon after power on.After removing battery & attaching it again, starts working again. why this issue is occuring..?


The antenna is too close to the module. You probably used the spiral antenna. Try using the PCB antenna with long (10cm) cable. Had the same problem, solved with the antenna.


Definitely related to poor antenna matching. This is complex stuff and should preferably be fixed by changing antenna matching (e.g. by a matching circuit or simply trying out a different antenna). I have also seen that it helps to wait until you get the unsolicited modem response "Call Ready". Until you get this message, it can disturb the modem to receive any AT command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.