0

The problem started when I tried to upload the Blink program to the module, it uploaded with no issues through Arduino but after that the blue LED didn't blink.

I searched a lot for it and found that the pin number may need to be changed.

So I uploaded this code

int LED0 = 0;
int LED1 = 1;
int LED2 = 2;

void setup() {
  pinMode(LED0, OUTPUT); // Initialize the LED_BUILTIN pin as an output
  pinMode(LED1, OUTPUT);
  pinMode(LED2, OUTPUT);
  Serial.print("LED_BUILTIN = ");
  Serial.print(LED_BUILTIN, DEC);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(LED0, LOW); // Turn the LED on (Note that LOW is the voltage level
  digitalWrite(LED1, LOW); // but actually the LED is on; this is because
  digitalWrite(LED2, LOW); // it is active low on the ESP-01)
  delay(1000); // Wait for a second
  digitalWrite(LED0, HIGH); // Turn the LED off by making the voltage HIGH
  digitalWrite(LED1, HIGH);
  digitalWrite(LED2, HIGH);
  delay(2000); // Wait for two seconds (to demonstrate the active low LED)
}

to ensure the blinking but still nothing out.

  • After that I tried AT commands and no replies also.
  • After that I did some searches and found that it may need to update the flash program and that's what I did.
  • No sync occurs until I remove and connect the power to the module while the tool is trying to sync. Otherwise, it gives a fail.
  • By removing and connecting the power to the module I was able to upload that flash,
  • But I still have the same problem - no reply from the module to AT commands and the blink output is nothing.

  • Finally I directly connected the TX to the 3.3 V and the blue LED is on so I figured that the problem is in the replying from the module.

Any help would be appreciated.

7
  • try pin 14. it is one of the used defaults.
    – Juraj
    Jun 30 '18 at 7:47
  • 1
    to put the esp8266 into flashing mode, pin 0 must be low at power-up or reset
    – Juraj
    Jun 30 '18 at 7:52
  • 1
    - tried 14 nothing new Jun 30 '18 at 7:56
  • 1
    also to upload a ketch to the module it has to be low and i did that already Jun 30 '18 at 7:57
  • 1
    i connected it to high to run the sketch but still the same goes Jun 30 '18 at 8:10
0

Hasn't the ESP8266 got different pin numbering? ie arduino pin 2 = pin 4 on esp8266, arduino pin 3 = pin 5 on esp8266, and arduino pin 4 = pin 2 on esp8266? and pin 4 on esp8266 is the built-in led. hope it helps.

2
  • NO, this is not true. some dev boars have pin labels and corresponding Dx constants, but not esp-01
    – Juraj
    Jul 12 '18 at 12:01
  • Ah, ok my bad. My reference to a different ESP8266 module. A picture/diagram of the connections would be helpful in finding how this circuit is connected up, don't you think?
    – Clu User
    Jul 15 '18 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.