0

I just got an Arduino nano (from arduino.cc, not a knock-off), and have issues uploading sketches. It refuses to upload, with the error message "programmer is not responding".

Some searching led to an incorrect transfer baud rate. Indeed, the IDE (1.8.5) output before uploading displays "overriding baud rate: 57600", and the command line has a -b57600 argument. By copying this command in a terminal and removing this parameter, the upload works. It also works with -b115200. All other values I tried do not work.

Is there a way to configure the IDE to use the correct baud rate ? I know I could use the command line, but that's not very practical, I would prefer to keep the Integrated part of the IDE :).

3

Update the boards package for the AVR hardware. That will give you new options in the tools menu.

Then you should just select the right CPU variant.

enter image description here

From top to bottom those are 115200, 57600 and 19200 baud.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.