0

I want to test around with my ESP32 and an E-Paper display - yet i am stuck at uploading sketches via Arduino IDE. I get those kind of errors:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x48

and looking into tools,i dont even see my board there - i bought it on amazon and the article just says "ILS - LOLIN32 Lite V1.0.0 Wifi and Bluetooth Board with ESP-32 Rev1 MicroPython 4MB FLASH".

What am i missing here? I am 99% sure i got the pins correct (finally), i got the USB-Serial driver, i got the right port - yet even a simple test sketch i found on the internet didnt work.

  • Uh.. have you installed ESP32 support in the Arduino IDE and have the correct board selected? Can you include a screenshot of your Arduino IDE when you try to upload the code? – Maximilian Gerhardt May 16 '18 at 8:51
  • what do you mean, "installed ESP32 support"? and i highly doubt i have the correct board selected i tried uploading multiple times on different board - but i dont know how to find out what board exactly i have in the IDE that. here is a screenshot: ibb.co/crQQLd – Flying Thunder May 16 '18 at 8:56
  • In the lower right corner you can see you have selected "Arduino Uno" board on COM3 as your target device. That's not what you want. You need to install the ESP32 Core for the Arduino IDE to be able to use the ESP32 boards and select it under Werkzeuge -> Board. Try to follow these instructions and check back if it worked: github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/… or smart-prototyping.com/blog/… – Maximilian Gerhardt May 16 '18 at 9:03
  • aah, i never heard of such thing being required to install - i always thought that ESP32 is just a generic name for those dev boards and that arduino boards are ESP32 with different specs. thanks, i will try to get that working for now – Flying Thunder May 16 '18 at 9:16
  • Clarification: "Arduino" is a framework / core. It is a set of functions (like millis(), digitalWrite(), digitalRead(), so to say. There are very different Arduino-Compatible boards (most famous: Arduino Uno / Nano / Mega, ESP8266, ESP32, STM32..). But since these boards are all from entirely different architecture (AVR vs XTensa vs ARM ..), they all need a different implementation of the Arduino Core. Thus you need to extend your Arduino IDE with more Cores for different board types to use them with the Arduino Framework. – Maximilian Gerhardt May 16 '18 at 9:21
1

The Arduino IDE does not have a core for the ESP32 installed by default.

The problem was solved by explicitly installing the ESP32-Arduino Core in the Arduino IDE according to their manuals

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.