I previously had issue updating code to Arduino Mega (clone). This is a continuation of this issue, but I think it should be made as separate thread.

After some time spending with it. Turns out if I change my USB port and connect it another USB port, the Mega is detected in port COM 6. I can upload code to the Mega using this COM port (COM6), although it shows an error sometimes. But if I change it back to the previous USB port (here the Mega detected as connected in COM9), I can't upload anything. You can see the error message in the above link.

I also have a Uno and tried uploading code to it through the same USB port (here it is detected as COM8), I can upload code.

I used the working COM (COM6) to upload Marlin FW to the Mega and I can connect my printer through the same COM port, but if I try it through COM9 I can't connect.

So why can't I use COM 9?

PS: I've been COM9 being used to communicate with the same Mega.

  • disconnect the arduino from your computer .... go to device manager in windows ... click view ... show hidden devices ... find COM9 and delete it .... plug the arduino back in and test the upload – jsotola May 13 at 1:21
  • Did that, i even uninstalled COM9. Still can't work with COM9 – Athul May 14 at 9:31
  • this is not an Arduino issue ..... i would say that it is some weird windows issue .... possibly something to do with the USB controller ... the two USB ports may be on different controllers .... you may also have an invalid device install file that windows is using to set up COM9 on that particular USB port – jsotola May 14 at 17:40
  • Is there anything I can do about this? – Athul May 15 at 5:46

Check to see if you have !!! In your code. This will fail the upload.

More details here: http://net-forces.blogspot.ca/2017/08/arduino-upload-timeout-and-in-string.html?m=1

  • It happens with whatever code I use (I tried arduino example codes). Like I said in the post, If I change COM port same code can be uploaded. but not with COM9. – Athul May 12 at 18:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.