1

Today I bought an mBot (from Makeblock) the one that uses 2.4G serial connection. After assembling it, I connected to it using mBlock (software based of Scratch) and I could control it using keyboard triggers. Then I went in Arduino IDE and used it to run some scripts on the mBot.

Next I tried to switch back to mBlock software, but now it cannot connect to the mBot anymore. Whatever Scratch-like scrips I build, they don't run anymore in mBlock.

Did I miss anything? Is there anything I can do so I can start using mBlock again?

  • 1
    There's probably some default firmware on the "mBot" (whatever that is) that is controlled by these scripts. Since you replaced that with Arduino code you're pretty much stuffed unless you can replace that original firmware. – Majenko Apr 15 '18 at 10:28
2

I received some really good piece of advice on the official forum and it solved my problem, it now works:

When you go back to using the mBlock (Scratch) environment you will need to reload the firmware (Upgrade firmware from the Connect menu item). At least that’s what I’ve had to do. Oh, and make sure that you have shut down the Arduino environment to release the serial port.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.