I recently had the Arduino IDE notify me of available boards updates, so I updated. Since then when I try to upload to my Nanos it fails:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x01

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

I installed Arduino IDE 1.0.6 and found that I can upload to all my Nanos with that IDE version.

How can I upload to my Nanos using Arduino AVR Boards 1.6.21?

  • 2
    The latest version of the Arduino IDE for windows is 1.8.5. What version are you running? What does "not work" mean? – jose can u c Apr 12 '18 at 19:08
  • Does not work needs more clarification. Can you even open the IDE? Does a sketch compile, but fail to upload? Does it upload, but the Arduinio doesn't run/operate? – jose can u c Apr 12 '18 at 19:54
  • Provide the actual error messages – jose can u c Apr 12 '18 at 19:55
  • what i mean is, since i updated the IDE a few days ago! none of my boards will not work with the updated IDE. i am using 1.8.5 sorry all 5 boards would not work, i have even tried a new NANO board i received today, and even it still will not work!! with 1.8.5 out of the 6 boards i have, i have only been able to get 3 nano's and 1 chinese arduino uno to work and that is only because i have downloaded the IDE 1.0.6 my original arduino uno r3 and another Chinese board still will not work! thank's for getting back to me :-) much appreciated. – David Harkness Apr 12 '18 at 19:56
  • 2
    Define "Not work". That phrase covers a multitude of possible issues. – Majenko Apr 12 '18 at 19:56

Arduino recently changed the bootloader they ship on their official Nano boards. This required a change in the hardware definition for the Nano, which was the sole reason for the Arduino AVR Boards 1.6.21 release.

The new Nano hardware definition is not backwards compatible with Nanos that use the previous ATmegaBOOT bootloader. For this reason a new menu option was added: Tools > Processor > ATmega328P (Old Bootloader). If you select that option the uploads to your Nanos will work again.

| improve this answer | |
  • just tried ATmega328P (Old Bootloader) still does not work :-( – David Harkness Apr 12 '18 at 20:26
  • 1
    it works, when i changed it, it was on com port 1, i just changed it to com port 3 and it work's now, thank you very much, i thought i had done all my boards in lol really thanks. :-) – David Harkness Apr 12 '18 at 20:33
  • 1
    Just tried the (Old bootloader) option after uninstalling and installing Arduino IDE. Really terrible problem. Couldn't figure it out. All the other boards (pro micro, mkr zero, etc) were working but not Nano. Really annoying but so glad I found this solution. Thanks! – raddevus Dec 11 '18 at 3:36

Check weather your arduino nano is Chinese having CH340G chip. If the chip is there then you have to install CH340G drivers in your computer..

| improve this answer | |

I also had similar issues after upgrading my Ubuntu system.

Selecting 3.3V for the Mini board did the trick, For the Nano, the old loader worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.