0

My lab partner and I are working on a project for school and we are using an Arduino Mega 2560 for prototyping. The board was working just fine until, out of nowhere, the board was not being recognized at all. I tried reinstalling the IDE but still it does not work. I checked to see if the Arduino driver was installed, but the board does not show up in the device manager. Also, the L LED on the board does not light up at all. Attached are photos to help understand the problem.

grayed out port in the tools drop-down

arduino mega driver does not show up in device manager

If someone could help, it would be much appreciated. Thanks.

migrated from electronics.stackexchange.com Apr 11 '18 at 3:25

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • Have you tried unplugging all the wires from the Arduino (other than USB) to verify it isn't a problem with something in your project shorting out? – Phil C Apr 11 '18 at 2:29
  • 2
    The board was working just fine until, out of nowhere, the board was not being recognized at all - out of nowhere, huh? What was the last thing you were doing with the board when it was working? – Nick Gammon Apr 11 '18 at 3:38
  • The last thing was upload a simple stepper motor code. – Jérémy Mainguy Apr 13 '18 at 2:42
  • Also, to answer Phil C, nothing is plugged to the arduino. – Jérémy Mainguy Apr 13 '18 at 2:42
  • If you guys have any other tips or tricks or advice in general regarding this issue, anything helps. – Jérémy Mainguy Apr 13 '18 at 2:44
1

hey i had the same problem, i am thinking because i installed atmel studio and then this started happening, I then downloaded arduino from the microsoft store,(no change) then i restarted the pc, now its compiling and uploaded normally but still does not show the name of the board that is connected just shows lets say just COM22 with out saying what board

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.