0

I'm facing this compilation issue.

Arduino: 1.8.4 (Linux), Board: "Intel® Edison"

fork/exec /home/jimish/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0/i686/sysroots/pokysdk/usr/bin/i586-poky-linux/i586-poky-linux-g++: no such file or directory Error compiling for board Intel® Edison.

Arduino IDE: Arduino IDE


Web IDE: Web IDE

  • 1
    please remove the two pictures and include the actual output text, so that text searches can be made. .... use the edit button – jsotola Mar 28 '18 at 20:13
  • I've already pasted error there. The pictures are proof, that it's not a fault of my local machine or local ide. @jsotola – Jimish Fotariya Apr 5 '18 at 5:30
  • @JimishFotariya - Have you tried to access this file from the command line? Usually its just a path issue. – Code Gorilla Apr 5 '18 at 12:09
  • @code-gorilla No i haven't tried that. But web-editor compiles on their server so I think it is a bug in original source. – Jimish Fotariya Apr 9 '18 at 6:50
  • This sounds like something you need to pursue with the creators of this non-Arduino toolchain. Either you have a broken install (does the file even exist?) or (if it is there but won't run) an issue like a 32 bit executable that won't run on a 64 bit system unless you install the optional 32-bit system libraries package. – Chris Stratton Apr 28 '18 at 15:47
1

The problem here is that Intel, in their infinite wisdom* have lots of hard-coded paths to libraries in the binaries (why, heaven only knows) and then a set of scripts that munge those binaries to sort out where the libraries really are.

That script uses an option to find that was deprecated 13 years ago.

Way to keep up with the times, Intel...

So you need to make some fixes to get the toolchain to install properly.

I have created "fix" scripts for both the Edison and the Galileo that you can use to replace your broken toolchain.


*i.e., sheer incompetence

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.