I have an Arduino Nano connected via a USB cable (Type A to Mini Type B) to my MacBook Air (Mid 2013 Model). The PWR LED is on while the arduino is connected.

Opening the Arduino software, pulling down the Tools > Serial Port menu does not show me a valid serial port. All I see is:


What I've tried and did not work

  • I have installed the correct FTDI driver (v2.2.18). x64 for my MacBook Air's Corei5, file FTDIUSBSerialDriver_10_4_10_5_10_6_10_7.mpkg. Restarted after installation.

  • Tried connecting arduino to both USB ports on my Air.

More Info

  • Running Mac OSX 10.10 Yosemite
  • Same arduino and cable work when connected to a Windows machine or a Raspberry Pi.

If it helps, I can see the USB Serial in my Apple Logo > About This Mac > System Report under Hardware > USB


  Product ID:               0x7523
  Vendor ID:                0x1a86
  Version:                  2.54
  Speed:                    Up to 12 Mb/sec
  Location ID:              0x14100000 / 8
  Current Available (mA):   500
  Current Required (mA):    Unknown (Device has not been configured)

I'm out of ideas and options. Any help would be greatly appreciated.

Thanks in advance :)

  • Is your nano a clone or a real nano?
    – PhillyNJ
    Commented Nov 22, 2014 at 12:09
  • It's a clone. Thought I've read that it's a real good one. Anyway, I found something that solved it for me. Going to put it as an answer.
    – Mecha
    Commented Nov 22, 2014 at 12:36
  • Did you have it plugged into a Windows machine first or before you plug it into your Mac?it might've been bricked but the good news is you can unbrick it.
    – PhillyNJ
    Commented Nov 22, 2014 at 13:09
  • First time I tried it on my Windows. But it turns out that I needed some additional driver for Mac. See my answer.
    – Mecha
    Commented Nov 22, 2014 at 13:13

1 Answer 1


This solved it for me.

  • Download this driver
  • Install it
  • Run sudo nvram boot-args="kext-dev-mode=1"
  • Reboot

Serial ports now showed up in the Arduino IDE and also when I used ls -1 /dev/tty*

Hopes this helps someone.

Reference: This thread

  • 1
    I have the same problem and using your link solves my problem. Thanks for sharing the information. Best Regards, Jo
    – user6274
    Commented Dec 16, 2014 at 15:37
  • 1
    On 2016-04-13, I downloaded the (version 1.2?, dated 2015-11-19?) driver from there, did the required reboot, and did not need to do the unsigned driver kext setting. On plugging it in, the device showed up as '/dev/cu.wchusbserialfa130' in Arduino/Tools/Port.
    – Dave X
    Commented Apr 13, 2016 at 17:31
  • 2
    Please update your answer to reflect the fact that it's not longer necessary to tinker with the OS X kernel to allow unsigned drivers to be loaded in kernel space which is a gigantic security risk. Latest OS X recognises these vendor and product IDs correctly, without the need to install any drivers. Product ID: 0x7523, Vendor ID: 0x1a86. Commented Apr 27, 2016 at 11:07
  • 1
    Yes, I am familiar with dates. For a novice, it isn't obvious which part of the answer is tinkering with the OS/X kernel, and which part isn't. I suggest you post your improved answer.
    – Nick Gammon
    Commented Apr 28, 2016 at 10:45
  • 2
    Beware! Kernel Panic! on macOS Sierra, as of 25th September, 2016. Commented Sep 25, 2016 at 14:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.