0

So I was trying to set up the LCD screen that came with my Genuino starter kit when I noticed that the board screen did not power on at all, unlike a few days ago when it worked.

In order to verify that the UNO was delivering power I simply connected an LED in series with a 220Ω resistor, between the 5V and ground pins. The LED did not power on.

I then, with the UNO still connected over USB, measured the voltage between across the resistor and LED and found it to be around 0.2-0.3V. Going further, reading the voltage between the 5V and ground solder connections on the back of the board and the reading is about the same.

I can power the LED from a digital pin that I set to HIGH, the issue seems to just be with the 5V pin.

Is there anything simple that I am missing (I hope there is) or is there likely a problem with my board? If there is a problem, could I use a digital pin to power a larger circuit such as that with an LCD or would the current supplied be too low?

  • 1
    Are you sure you have the 5V pin and not Vin? And that driving an LED from a digital output worked under the same circumstances where the 5V pin did not? – Chris Stratton Mar 14 '18 at 22:49
  • Positive, disconnecting only the power connection and moving it to either 3.3V, Vin or a HIGH digital output results in the LED powering on. – fanduin Mar 14 '18 at 22:55
  • Maybe you should try where the pin sticks through the bottom of the board. It is possible for the sockets you plug into from above to fail mechanically and not make contact with whatever you plug in. – Chris Stratton Mar 14 '18 at 22:59
  • I have tested both the sockets and the solder connections under the board to no avail, the behaviour is consistent. – fanduin Mar 14 '18 at 23:03
  • Power it off, get an ohm meter with sharp leads and start tracing continuity from the ATmega VCC pin to the inactive 5v pin. Or if your time is worth more than the board, replace it. – Chris Stratton Mar 14 '18 at 23:05
0

There are a couple more places you can sample the 5V signal, see the photo here:

Arduino Uno

On the right, on the ICSP header, the pin marked VCC is also connected to the 5V signal. Try testing that.

(The other one is pin 2 of the ICSP interface for the USB chip, but the one on the right should be adequate for testing).

I don't know why you are mucking around with LEDs and resistors, just put your meter between Gnd and 5V.

I find sometimes that the hookup cable has failed, try testing that (or try with a different cable).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.