3

I am posting a possible solution here for any online searches happening upon this exact issue.

So I have a third party board (Mega 2560) and I was plagued with my board intermittently working, on some rare occasions it worked but in most cases it just threw me the "USB device not recognized" after plugging it into my pc.

Upon closer inspection I have noticed the followingNot the best of jobs eh?

The one coupling capacitor (Blocks DC but allows AC and signal to pass) was poorly soldered, barely making contact!

So if your pc intermittently connects to your arduino, maybe check what the physical signal path looks like, you might find something like this.

1
  • We are getting the same error completely out of the blue. We have an Arduino Uno board. We have tried just about everything from changing out the USB cable, uninstalling ALL programs associated with our machine and reinstalling them. Changed settings, updated our computer, used a different laptop to see if our computer was the issue (no problems there). Thought it was a driver issue to redownloaded and attempted updating... no go... Help! We as a last resort have ordered a new Arduino Uno... Have we not thought of something to check? Thanks ahead of time!
    – Stewart
    Dec 13 '20 at 19:53
3

enter image description here

SMD soldering is not easy but here is the fix. Continuity achieved!

2
  • 1
    Continuity achieved but... Did this solve the problem? Did you get again some errors or not?
    – frarugi87
    Mar 12 '18 at 9:18
  • 1
    It did solve the problem. Zero errors afterwards, connected every time I plugged it in. It does seem that the capacitor was to blame
    – Rigknot
    Mar 13 '18 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.