1

So this is the second time that I've had a circuit that worked perfectly on a breadboard, but as soon as I connected it to a perfboard and soldered the joints together, the Arduino stopped working and wouldn't let me upload sketches (though I could see a COM port for it).

I'm using lead-free solder for the first time, and had the temperature at 750 deg Fahrenheit, and I'm thinking that while I had quick joints to connect the Arduino to the perfboard, when bridging two joints with solder, the iron might have been heating the header pin for 4-10 seconds... Is that enough to break the board?

my perfboard joints

(note - I'm using jumper wires on the other side to connect everything up, and I've already checked the board's connections using a multimeter and they're all as intended, and there are no accidental shorts/bridges)

  • 1
    That's rather unlikely, especially as your Arduino is a module rather than a bare chip, there's a fair amount of distance between the pins you are soldering on and those of the chip. Melting the plastic web of the headers would be more likely though of little consequence once mounted. Unfortunately, it's not really possible to tell what is actually wrong from the very limited information in your question. – Chris Stratton Mar 3 '18 at 17:20
  • -1 for lead-free. -1 for not enough flux. pro-tip: use a socket or female pin headers instead of welding to the board; prevents heat damage and lets you swap out failed parts. – dandavis Mar 4 '18 at 6:18
2

I would like to clarify that my only question in ENTIRE post was: "Is that enough to break the board?"

The answer to that narrow question is that heat from soldering with an iron is extremely unlikely to have done this. IC's are in practice (vs data sheet) quite heat tolerant, and further the pins you are soldering on are not even the pins of the IC or any electronic components, but rather those of the module headers. You'd be more likely to melt the plastic web between those headers pins, but even that won't be a great problem since they are already in place. Or if you were soldering directly on the board, lifting a pad or trace - but you were not doing that.

Your actual problem is something else, what that might be is presently unanswerable due to the lack of detail in your question.

  • yeah, I'm also really perplexed at what my actual problem might be, so I've already asked an entire other question about it with more detail - arduino.stackexchange.com/questions/50329 . I'll admit, my problem is ambiguous so even though that post has as much detail as I can think to include, I'm really stumped and not sure it's the kind of question that can be answered without being physically present – Austin Fennacy Mar 5 '18 at 15:59
0

Bridging adjacent pins by heating for 10 seconds is not a great way of doing things. You are trying to cross the "solder resist" with solder, so you are basically fighting something.

I normally use some tinned copper wire to cross gaps like that. You should be able to keep the soldering times down to a couple of seconds.

Did I overheat my Arduino ... ?

We can't really say from where we sit, but maybe.

I could see a COM port for it

The Pro Mini doesn't have a USB chip, so how are you programming it?


I am using an FTDI breakout board to program the Pro Mini, which then attaches to a USB cable.

Right, well you are seeing the COM port from the FTDI breakout board, not the Arduino as such. You would see that even if there was no Arduino there at all.


The soldering on one of your pins (5th from the bottom, on the right) looks a bit dodgy. It might just be the light.

As I said earlier, you possibly overheated the processor chip. I would use the technique I described rather than a 10-second heat.

See my question/answer: Have I bricked my Arduino Uno? Problems with uploading to board - that describes various tests you can do to check if the processor is still good.

  • 1
    This is not much of an answer... Seems like this should be a comment – Chad G Mar 3 '18 at 9:24
  • 2
    It's like asking "did I burn my roast beef"? How are we supposed to know that? However we can talk about ways that roast beef could be burnt. Feel free to post a better answer. – Nick Gammon Mar 3 '18 at 9:36
  • 1
    We arent, and there isnt one. Questions do not require an answer, if there is none, there is none. – Chad G Mar 3 '18 at 9:38
  • 2
    I would like to clarify that my only question in ENTIRE post was: "Is that enough to break the board?" This question objectively has an answer. I simplified the question in the title so that people would know what this post is about, but if the answer is "yes, that could break the board," then follow-on tips on how I can not overheat future circuits would be appreciated (?) – Austin Fennacy Mar 4 '18 at 0:12
  • 1
    I am using an FTDI breakout board to program the Pro Mini, which then attaches to a USB cable. – Austin Fennacy Mar 4 '18 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.