1

So I have a circuit that works well when it's on a breadboard and without removing any pins I'm able to upload sketches, but for some reason when I transition it to a protoboard I can no longer upload sketches.

My circuit consists of an MPU6050, an Arduino Pro Mini, and a HC-08 BLE module. I've tried protoboarding this circuit twice with Arduino Pro Minis and once with an Arduino Nano, and now I'm not able to upload sketches to any of these three circuits.

I'm using perfboard (not stripboard, so yes I have already connected the jumper wires to the header pins) and know that the circuit partially works since the IMU, Arduino, and BLE LEDs all light and you can connect to the BLE on a mobile terminal app.

The error I get is:

avrdude: stk500_getsync(): not in sync: resp=0x00,
  • I use SoftwareSerial.h so NO pins are connected to the Arduinos 0 and 1 pins.
  • I've already tried restarting the IDE
  • I've tried disconnecting/reconnecting the USB cable
  • There's only one COM# port so I'm sure I'm using the right one.

I'm so stumped because this error message did not occur when I was playing with the same circuit on a breadboard...

Any ideas on how I can fix this or what I'm doing wrong?

  • something is probably pulling the power down .... disconnect the arduino from the circuit and try loading – jsotola Feb 28 '18 at 23:07
  • 1
    Did you remember to include all the bypass capacitors? – Majenko Feb 28 '18 at 23:31
  • .. I'm using an arduino Pro Mini, and didn't use any bypass capacitors in my breadboarded circuit, can you clarify? – Austin Fennacy Mar 1 '18 at 3:22
  • Maybe post a sketch of your circuit? – idkfa Mar 5 '18 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.