I had problems with Arduino uno and reseted firmware. Followed this tutorial. Now I can't upload my code Arduino IDE says:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

I tried loop-back mode, everything is fine.

Firmware was located in this location:

  • It looks like you changed the bootloader which would change the behaviour of arduino ide (ie there is no arduino bootloader to connect it to). You might want to look into reflashing the bootloader. – Treesrule14 Nov 17 '14 at 19:36
  • Can't you tell me how to do that? – Solo Omsarashvili Nov 17 '14 at 19:46
  • Writing bootloader from Arduino IDE throws the same error – Solo Omsarashvili Nov 17 '14 at 19:47
  • I was talking about the actual software that arudino uses to load up the code see here arduino.cc/en/Hacking/Bootloader?from=Tutorial.Bootloader It would help if you have another arudino to work with – Treesrule14 Nov 18 '14 at 18:45

There are two processors on the Uno board.

  • The Atmega328P which is the "main" processor with your sketches on it
  • The Atmega16U2 which handles the USB interface

Firmware was located in /usr/share/arduino/hardware/arduino/firmwares/atmegaxxu2/Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex

Hopefully you reflashed the Atmega16U2 with that file. Did you?

I tried loop-back mode, everything is fine.

Therefore the Atmega16U2 is OK. The problem may be with the Atmega328P.

I had problems with Arduino Uno and reseted firmware.

You shouldn't need to do this, I never reflash the firmware on my Atmega16U2.

What problems did you have? Did it involve motors? LEDs? High voltages? Sparks? Flames? Screaming?

Please see the steps described here, run through them, and see if that fixes the problem: Have I bricked my Arduino Uno? Problems with uploading to board

Not the answer you're looking for? Browse other questions tagged or ask your own question.