2

I'm really at my wits end. For a couple of hours I have been programming a custom board that uses everything as on the Arduino Leonardo. A few hours ago I am not able to upload anymore.

I get the following error:

   avrdude: error: buffered memory access not supported. 
   Maybe it isn't a butterfly/AVR109 but a AVR910 device?

I've tried everything from re-installing the IDE, re-installing the board in Device Manager, changing the COM Port. I really just don't know anymore.

Here is some more data that might be relevant or useful:

     Using Port                     :\\.\COM6 
     Using Programmer              : avr109
     Overriding Baud Rate          : 57600
     AVR Part                      : ATmega32U4
     Chip Erase delay              : 9000 us
     PAGEL                         : PD7
     BS2                           : PA0
     RESET disposition             : dedicated
     RETRY pulse                   : SCK
     serial program mode           : yes
     parallel program mode         : yes
     Timeout                       : 200
     StabDelay                     : 100
     CmdexeDelay                   : 25
     SyncLoops                     : 32
     ByteDelay                     : 0
     PollIndex                     : 3
     PollValue                     : 0x53

[EDIT] I've now checked the battery (yes with a multimeter), it is fully charged, as it charges when the USB is connected. I've also tried a different computer, along with a different USB cable.

  • Did you try telling it to use the incorrect programmer? – Treesrule14 Nov 6 '14 at 12:59
  • Do you mean changing the programmer within the IDE? It is currently set to AVRISP mkll. I've now tried all the alternatives available in the IDE, still no luck. – Ricium Nov 6 '14 at 15:55
  • What IDE are you using? Do you have the arduino bootloader installed? – Treesrule14 Nov 6 '14 at 16:26
  • The standard Arduino IDE, tried both 1.0.6 and 1.5.8. And yes, the bootloader is installed as I have previously uploaded sketches to the board – Ricium Nov 6 '14 at 17:37
1

Try this:

First: you must find the COMx used for your "Arduino Leonardo" in the "Device Manager" of Windows.

Second: make double click to see the properties of the device, and go to the "Port configuration tab"

Third: enter in "Avanced Options" and deactivate "Use FIFO buffers", and accept all changes.

  • Tried it, still nothing. Do you think the bootloader may have caused a random error, or get corrupted or something? - is that even possible. I'll try to reload the bootloader, and see if it works (this part is still new to me), but I would like to know what causes this error? Maybe then I can stop it from happening in the future. Thank you for the reply – Ricium Nov 8 '14 at 13:32
  • Always check if you didn't accidentally blow the crystal! But thank you, checked on another Leonardo board, this worked. – Ricium Dec 2 '14 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.