1

I'm new to the Arduino (I'm a developer but didn't have a chance to work with this kind of device before) and wanted to connect my ESP8266 to the Arduino Uno. I followed this tutorial but I got errors:

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_memfailed
error: espcomm_upload_mem_failed

I tried running WiFiScan from the examples. I've installed SiLabsUSB Driver (I'm on macOS) and tried different solutions across the internet and I couldn't make it work. There are screenshots of the settings.

enter image description here enter image description here

  • that error usually means the ESP isn't in programming mode when you try to upload a compiled sketch to it – Jaromanda X Jan 18 '18 at 23:25
  • @JaromandaX so how to put in the programming mode? – mikro098 Jan 18 '18 at 23:34
  • 1
    Of course, I'm assuming you're trying to flash new firmware onto the ESP-01, if so, read the tutorial again - see step 19 in the tutorial you "followed" – Jaromanda X Jan 18 '18 at 23:36
  • @JaromandaX actually I didn't get to the 19th step as I couldn't get past step 2 but this flasher contains only .exe file and I'm on mac – mikro098 Jan 18 '18 at 23:38
  • 1
    @Juraj - According to the data sheet the pins of most ESP are 5V tolerant, I think I remember they support 6.7v but please check, before you trust me. (There is a post on here about it somewhere) – Code Gorilla Jan 19 '18 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.