1

I don't have a correct serial port from the resource I'm working from - Getting Started with Arduino by Massimo Banzi and Micheal Shiloh. I'm using the Arduino Uno. I'm a complete noob to Arduino. In this image below, from the resource I'm working from, it specifies to use either of the ports: /dev/cu.usbmodemfa141 or /dev/tty.usbmodem.

Getting started with Arduino by Massimo Banzi and Michael Shiloh - Figure 3-2 shows a list of available serial ports.

enter image description here

I only have two available: /dev/cu.SSDC and /dev/cu.Bluetooth-Incoming-port.

How do I get the 'correct' serial port? Correct being: /dev/cu.usbmodemfa141 or /dev/tty.usbmodem.

Here's some possibly useful information:

I'm using Mac OS - which I'm new to - Sierra version 10.13.2.

I only have two ports on the computer a USB type - C and a headphone jack. So I have an 'adapter' that allows me to 'daisy chain' the USB - B and USB - A for the Arduino cable into the port of my computer. If any additional information is required, feel free to ask for it and I'll try and get back to you ASAP. Thanks.

  • 1
    Is it a genuine Arduino Uno or some cheap Chinese POS? – Majenko Jan 11 '18 at 16:33
  • 2
    He or she has asked the same question before, and it's apparently a genuine starter kit – jose can u c Jan 11 '18 at 16:37
  • Yes genuine it's a genuine starter kit. – Please don't judge me. Jan 22 '18 at 15:01
  • Any sources of information or suggestions would really help. – Please don't judge me. Jan 22 '18 at 15:02
0

I had the same problem and had even fewer options under my Tools > Port menu. Looked at the user forums but most answers did not work for me. After watching a YouTube video, I fixed the problem by following its suggestion of installing the CH34X driver. There are some other suggested drivers if you search for some other related StackOverflow and StackExchange posts, but I did not test them (once the Mac-Arduino communication worked, I did not want to spend more time on this) and nor can I explain why this solution works.

I wrote a short article on this for myself. If you are interested, please take a quick look.

Best luck! :)

0

Sorry guys I solved it. It was really simple I just needed to plug the device in and it then detected the device and port name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.