I'm trying to use a Nano v3 as ISP to program an atmega328p on a board with ISP headers:

I followed the instructions under https://www.arduino.cc/en/Tutorial/ArduinoISP which I think have been recently updated. I'm simply connecting ISP headers together except for D10 from programmer to reset on the target AVR.

enter image description here

The ISP sketch seems to be working fine as far as I can see the heartbeat pulsing a led. But when trying to burn bootloader with settings:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x01
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x10
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): unknown response=0x12
Error while burning bootloader.

I noticed something weird though, the 5V and GND on the ISP header on the programmer nano only has around 0.4V. This even without anything external but the usb connected. Is my nano broken or is the usb connection not able to deliver enough power?

  • If the vcc from your nano is down to 0.4v then the board you are trying to program is not getting any power and it wont work. You have to make sure that both the nano and the board atmega328 you are trying to program are both supplied with power AND THAT THEY ARE RUNNING OFF OF THE SAME SUPPLY VOLTAGE. Only then is it going to work. The reason you are only measuring 0.4v could be because the target board is drawing too much power.
    – Vinzent
    Commented Jan 8, 2018 at 14:06
  • If it's down to 0.4 V then there might be an almost-short circuit somewhere. Commented Jan 8, 2018 at 14:46
  • Turns out I was an idiot when I took that picture and did the measurement. I had simply turned the ISP header upside down :(. I'm at 4.7V which should be fine. Still same error though. Commented Jan 8, 2018 at 16:34

2 Answers 2


Your slave micro isnt resetting when your master wants it to reset.

Ie: master sends a reset signal before initiating further communication, and it seems that your slave not being reset.

So its not responding.

Once cross check your isp signal lines.


Try adding the 10µF capacitor connected to RESET and GND on the board you are using as programmer (in this case, your Nano). This is required according to the Documentation.

The 10µF electrolytic capacitor connected to RESET and GND of the programming board is needed only for the boards that have an interface between the microcontroller and the computer's USB, like Mega, Uno, Mini, Nano.

I just encountered the exact same error output, and the capacitor solved it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.