0

I recently purchased several of the DFRobot ledkeypad shields: https://www.dfrobot.com/product-1407.html

I have Arduino Leonardo (which also had some problems in the beginning, being recognized as modems). My OS is Linux Mint, and I'm using the last Arduino IDE.

The library I use is the one recommended on the website of the vendor, LedKeypad.h, and works fine with the other shields of the same model from the same batch.

Some shields worked fine but I am now having trouble with one of them, which seems unresponsive. I can load for instance the blink program in the arduino, and it works, but the shield does not work. When it is plugged in, the fours dots are slightly red, and I cannot turn them off.

I tried displaying something on the serial monitor when the buttons are pushed, and only one of the 5 buttons works (the KEY_DOWN one).

Is there anything I can attempt to fix the problem ? Or should I just give up on this shield ?

4
  • 1
    the information that you have posted is incomplete. ... there is no mention of software ... please include all info in the question ... do not use comments to add info – jsotola Dec 25 '17 at 19:41
  • @jsotola added software info, is all the relevant information there ? – Denis Dec 25 '17 at 21:54
  • what i am talking about is that you made no mention of any libraries for the arduino. there is no way to tell if you downloaded the correct libraries. – jsotola Dec 26 '17 at 2:08
  • @jsotola oh sorry I added info about the library – Denis Dec 26 '17 at 12:29
-1

... and works fine with the other shields of the same model from the same batch.

So had you considered that the shield might be faulty? Have you contacted the manufacturer or vendor for support?

2
  • The schematic seems to show that it uses the actual SDA/SCL pins on the digital header (next to Aref) instead of A4/A5, so it should be compatible with other boards as well. The buttons are just a voltage divider connected to an analog input, so that should work with the Leonardo as well. – tttapa Dec 26 '17 at 9:58
  • 1
    I had not seen that. – Majenko Dec 26 '17 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.