-1

My circuit is as seen and I hope there is no error with the wiring. I'm using an ATmega328P. The error suggests that the programmer is not responding and ten attempts issuing not in sync code. There isn't any bootloader issue as pin 13 LED flickers as soon as I plug in USB cable. I have selected the following board specification in the Arduino IDE:

  • Board: Arduino Uno
  • Programmer: Arduino as ISP

Schematics I followed:

schematics

ATmega pinout reference:

reference

Connections:

  • Pin 1: 10k resistor to 5V, 0.1uF capacitor pin series with DTR of FTDI

  • Pin 2: Tx of FTDI

  • Pin 3: Rx of FTDI

  • Pins 9 & 10: 16 MHz oscillator and 22pf capacitor in series

  • Pins 7, 20, 21: 5v

  • Pins 8, 22: ground

  • Pin 19: status LED (similar to pin 13 LED on standard Arduino Uno)

I used both ways of uploading (directly and upload using programmer) and nothing worked. The bootloader in the chip is that of the Arduino Uno and it was burned using another Uno board. SPI programming using another Uno board works fine. I tried different combination of programmer in IDE but futile. The capacitor for reset is 0.1 µf and it seems that connections are fine as there was no issue with uploading using another Uno board as ISP.I would love if anyone can help me out with this.

Related images are:

the error

arrangement on breadboard

PS: [Post comment changes]

-I added a 47uF and 0.1uF caps for cleaner supply to the chip based on suggestions in comment section.

  • board with changes[by pass capacitors ,resistor visible on pin 19] [changes made]5
  • IDE specifics serial output

Solution-

  • credits- @Nickgammon

  • had problem with bootloader which was initially uploaded . later solved it by following instructions from NickGammon Forum - http://www.gammon.com.au/breadboard

related images-

  • snap shot from bootloading window in arduino IDE serial output
0

Here is a photo of the setup I used on this page about a breadboard Arduino. I can't see any material differences between yours and mine, except that I wouldn't connect Aref (pin 21) to anything.

Minimal Arduino

Close-up of the FTDI connection:

FTDI interface

I have 0.1 µF capacitors as decoupling capacitors on both sides of the breadboard.

I used both ways of uploading (directly and upload using programmer) and nothing worked.

Assuming you have the Uno bootloader installed (and that the fuses are still set to what they should be for a Uno) then you want direct uploading (with board type set to Uno), not uploading via a programmer.

  • I have a 47uF and 0.1 uF as decouplers. I'll see if removing AREF will help. I believe there isn't any issue with bootloader as i could program it using an actual arduino board as ISP and program runs effectively. – Raul Dec 22 '17 at 3:47
  • If you program using and Arduino as ISP then you are doing SPI programming, so that doesn't prove much. It also will remove any existing bootloader. The flashes you see on the LED might just be the blink sketch. – Nick Gammon Dec 22 '17 at 3:50
  • If you run run my board detector sketch it will confirm whether or not there is a bootloader there. – Nick Gammon Dec 22 '17 at 3:51
  • I realize the flaw in my point regarding bootloader, I'll check through "board detector sketch".By flickering i mean,rapid flashes and also the same when i hit upload button during FTDI serial programming method,but error crops up at the end.It seems like chip is communicating and resetting the board but still cannot upload – Raul Dec 22 '17 at 4:01
0

The first thing to try is changing the Programmer to "AVRISP mkII". This was the "default", "selected" programmer in my IDE since day one of it's install on my computer and it works with the Uno and Atmega328-PU IC.

I have the same FTDI programer that you are using, I've tried the 0.1uF capacitor on the DTR line to Atmega328-PU "method" and found it to be "flakey", at best.

Use the "push button switch" at the right moment to upload your sketch. The "right moment" varies, but try this: Click the Upload Button in the IDE. As soon as you see the "Binary sketch size: …" in the debug window, press the reset button and hold it down for one second, then release it.

Once you figure out exactly when to press the button, and how long to hold it down for, you'll find this method is almost 100% reliable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.