1

I've recently bought a batch of ATTiny85 modules (Digispark clones) from China, and tried to write a first test program into them now. I noticed that they do seem to have some bootloader already installed since the P1 LED is flashing, but they do not seem to make any reasonable USB handshake. (I have ordered other seemingly identical modules from a different seller on Ali before and was able to use them just fine.. so I generally know how to work with these.)

Linux dmesg shows me that a device was plugged in, but does not get any vendor or model ID. Windows tells me that 'the device last plugged in has failed enumeration'. This looks to me like the bootloader is incomplete or somehow broken.

So, as a next step, I tried to rewrite the AVR with an USBASP adapter over ISP, only to find out that the /reset pin apparently has been disabled via fuse bit.

I'm in some kind of a loop now... If the bootloader doesn't speak USB correctly, I can't use the Arduino IDE or avrdude or anything to write to it, and if the /reset is remapped I can't replace the bootloader via ISP to get USB working.

Can anyone provide a hint on how I can get these modules to work? Or should I just assume I bought a bad batch, throw them away and order fresh ones?

migrated from electronics.stackexchange.com Dec 18 '17 at 1:47

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • 1
    maybe you shouldn't order fresh ones, but not from sketchy Chinese clone manufacturers? Just a hunch, though... – Marcus Müller Dec 18 '17 at 0:56
  • maybe there is no usb firmware loaded into the devices ... can you post the seller's device homepage? – jsotola Dec 18 '17 at 1:04
  • @jsotola Their page said "arduino compatible" and the same standard feature list copied from all other vendors on AliExpress. A non-usb firmware makes little sense, since ISP needs a working /reset pin which is definitely deactivated... – WooShell Dec 19 '17 at 15:57
  • "arduino compatible" may be referring to the hardware – jsotola Dec 19 '17 at 18:06
1

I had problems too - SHORT: all about USB-hub or PC's root-hub and extension cables +Luck.

My ebay items were going under the name "Digispark Kickstarter ATTINY85 Arduino Micro USB Development Board" and naturally it came with no Digispark-(c)-right infringing markings from China. I kept my fingers crossed that my items would at least be AVRisp-programable..

So in high hopes I plugged in my China import into my trusty USB HUB2.0(which I always use at least as a current limiter) – after testing it first on a powerbank (>5secs blinky-blink) .. checked for enumeration (which it did-but no driver yet) .. installed the DPinst[64].exe drivers.. and then kept getting messages like >>device failed to enumerate<<, etc. - the list of my failures:

  • determined directly plugged into a PC's USB root-hub rigged/minimalistic usb devices do not enumerate at all (all 0s)

  • with a certain USBAmale-to-USBAfemale extension cable with plastic-encasing(female side) the USBA device’s was not allowed to go "in" probably just for some millimeters to short.. the Data-lamella do not connect correct – just power's okay (blinky-blink) .. but no Windows device-recognition .. No-No!

  • AND reminding the FTDI black-listing dilemma I used PCs without out the drivers still – using the good old “USBview.exe” program to check on the enumeration (on all my available device the same .. previously plugged into my driver-enable PC or just into an “out of the fab”-one

    idVendor:           0x16D0
    idProduct:          0x0753
    bcdDevice:          0x010B
    

so no mis-configuration of the bootloader through a >possibly mallign< Digispark clone dis-configurator (as I was thinking the FTDI schemes .. of course FTDI only did it to protect their name X-) – to stop getting accused for faulty devices coming from cheap chinese fake or clone-producers) * EVEN tried to deinstall the Drivers with DPinst[64].exe /D .. which gave me .. Yes .. yet again “Drivers all installed properly!”..

.. and IN THE END .. I just went back to my old, initial “USB HUB-behind root-hub” configuration .. and Abra-ca-Zang .. the device just enumerated and registered as “Digispark Bootloader” (windows device manager under libusb-win32 Usb Devices)

and all went okay - reprogramming with the Arduino IDE - NO FUZZ! .. The !very same! config I was using on my “first testings” (minus some fair time and headaches of debugging)

So my advice .. always do a Basic-Test on a USB Powerbank, USE an USB-Hub, check your cables - use ones you trusted before! – try as many options as you (may) have .. and use the tools at your hand .. down to PC-progs or an logic-analyzer or an Beagle USB / protocol analyer to check where the problem may be.. trace back your tracks and even retry..

There may be a suprise for you at the end of the rainbow!

1

Using Arduino IDE 1.8, I had a Windows did not recognize USB Device message.

I successfully installed the DigiSpark drivers but still the PC was not recognizing the Tiny85 development board. In the Arduino IDE I had initially selected the DigiSpark (16.5 MHz default) as instructed in a YouTube video. I did some more research, someone suggested trying a different board. I selected the DigiSpark (No USB 16 MHz) uploaded the Blink example.

The LED started to flash and windows stopped complaining about the unrecognized device. I removed the flashed board and plugged in another, Windows started complaining, I uploaded the sketch successfully windows stopped complaining. I removed the second board and installed the first one and there were no further issues with Windows.

  • What YouTube video, do you have a link? – Greenonline Nov 12 '18 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.